您的位置:首页 > 其它

PAT A 1072. Gas Station (30)

2014-05-25 12:57 288 查看
题目

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution
is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas
stations; K (<= 104), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that
all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate
up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution


把备选station编号至house后面当成一个图,然后将各station依次作为0点算个点距离。扫一下各个house,求所需数据,求出最佳。

代码:

#include <iostream>
#include <cstdio>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;

const int MAX=0x1fffffff;

int To_num(const string &s,int n);	//将字符串转为数字,对G开头的去G加n

int main()
{
int n,m,k,d;
cin>>n>>m>>k>>d;

int i,j,p;
int **map=new int* [n+m+1];	//地图信息,house从1~n编号,station从n+1~n+m编号
for(i=0;i<n+m+1;i++)
{
map[i]=new int [n+m+1];
for(j=0;j<n+m+1;j++)
map[i][j]=MAX;
}
int *dis=new int [n+m+1];	//距离信息

char ctemp[7];	//实测直接cin>>s1>>s2速度差不多
string s1,s2;
int p1,p2,t_dis;
for(i=0;i<k;i++)	//输入地图信息
{
scanf("%s",ctemp);
s1=ctemp;
p1=To_num(s1,n);
scanf("%s",ctemp);
s2=ctemp;
p2=To_num(s2,n);
scanf("%d",&t_dis);
if(p1!=p2&&map[p1][p2]>t_dis)
{
map[p1][p2]=t_dis;
map[p2][p1]=t_dis;
}
}

int *flag=new int [n+m+1];	//标记相应点是否已用于松弛,1表示已经用于松弛
int min,mt;	//用于松弛的点,此轮搜索到的下轮用松弛点

int best=0;	//station最佳选择
double min_dis=-1;	//最短距离
double avg_dis=MAX;	//平均距离
double temp_min;	//此轮扫描状态中的最短距离
double temp_avg;	//用于计算相应选择的平均距离
for(i=1;i<=m;i++)	//依次选择各个station
{
temp_min=MAX;	//初始化
temp_avg=0;
for(j=1;j<=n+m;j++)
{
dis[j]=MAX;
flag[j]=0;
}
min=n+i;
dis[min]=0;
flag[min]=1;
mt=0;
dis[mt]=MAX+1;

while(1)	//dijkstra
{
mt=0;	//重置此轮最小点
for(p=1;p<=n+m;p++)	//松弛最小点
{
if(p!=min&&dis[min]+map[p][min]<dis[p])
dis[p]=dis[min]+map[p][min];
if(flag[p]==0&&dis[p]<dis[mt])
mt=p;
}
if(mt>0)	//还有没用于松弛的点
{
min=mt;
flag[mt]=1;
}
else		//松弛结束
break;
}

for(j=1;j<=n;j++)	//获取选择相应station的数据
{
if(dis[j]>d)	//跳过不符合情况
break;
if(dis[j]<temp_min)
temp_min=dis[j];
temp_avg+=dis[j];
}
if(j<=n)	//跳过不符合条件的情况
continue;
temp_avg/=n;
if(temp_min<=d)	//考虑是否更新最佳选择
{
if(temp_min>min_dis||
(temp_min==min_dis&&temp_avg<avg_dis))
{
best=i;
min_dis=temp_min;
avg_dis=temp_avg;
}
}
}

if(best!=0)	//输出
{
printf("G%d\n",best);
printf("%0.1lf %0.1lf",min_dis,avg_dis);
}
else
cout<<"No Solution";

for(i=0;i<n+m+1;i++)
delete[] map[i];
delete [] map;
delete [] dis;
delete [] flag;

return 0;
}

int To_num(const string &s,int n)
{
int num=0,limit;
int i;
if(s[0]!='G')
limit=0;
else
limit=1;
for(i=limit;i<s.size();i++)
{
num*=10;
num+=s[i]-'0';
}
if(limit==1)
num+=n;
return num;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: