您的位置:首页 > 其它

BZOJ [Usaco2007 Jan]Protecting the Flowers 护花(隐藏题)

2014-05-25 11:23 579 查看

Description

Farmer John went to cut some wood and left N (2 <= N <= 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cows were in his garden eating his beautiful flowers. Wanting to minimize the
subsequent damage, FJ decided to take immediate action and transport the cows back to their barn. Each cow i is at a location that is Ti minutes (1 <= Ti <= 2,000,000) away from the barn. Furthermore, while waiting for transport, she destroys Di (1 <= Di <=
100) flowers per minute. No matter how hard he tries,FJ can only transport one cow at a time back to the barn. Moving cow i to the barn requires 2*Ti minutes (Ti to get there and Ti to return). Write a program to determine the order in which FJ should pick
up the cows so that the total number of flowers destroyed is minimized.

   约翰留下他的N只奶牛上山采木.他离开的时候,她们像往常一样悠闲地在草场里吃草.可是,当他回来的时候,他看到了一幕惨剧:牛们正躲在他的花园里,啃食着他心爱的美丽花朵!为了使接下来花朵的损失最小,约翰赶紧采取行动,把牛们送回牛棚. 牛们从1到N编号.第i只牛所在的位置距离牛棚Ti(1≤Ti《2000000)分钟的路程,而在约翰开始送她回牛棚之前,她每分钟会啃食Di(1≤Di≤100)朵鲜花.无论多么努力,约翰一次只能送一只牛回棚.而运送第第i只牛事实上需要2Ti分钟,因为来回都需要时间.    写一个程序来决定约翰运送奶牛的顺序,使最终被吞食的花朵数量最小.

Input

* Line 1: A single integer

N * Lines 2..N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics

    第1行输入N,之后N行每行输入两个整数Ti和Di.

Output

* Line 1: A single integer that is the minimum number of destroyed flowers

    一个整数,表示最小数量的花朵被吞食.

Sample Input

6

3 1

2 5

2 3

3 2

4 1

1 6

Sample Output

86

HINT

    约翰用6,2,3,4,1,5的顺序来运送他的奶牛.

题解

虽然是一题很水的贪心。但是作为这周模拟赛的一道题,我的程序崩溃了一次,wa了一次。原因如下:1、time在c++自带的库中,最好不要作为变量。2、贪心时,排序的标准要靠不等式推,不能只看样例。
下面是正确的代码:

#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int n;
long long tim,ans;
struct hua{long long t,c;} a[100002];
bool kp(const hua &x,const hua &y)
{return x.t*y.c<y.t*x.c;}
int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++) scanf("%lld%lld",&a[i].t,&a[i].c);
sort(a+1,a+n+1,kp);
for(int i=1;i<=n;i++)
{ans+=tim*a[i].c;
tim+=a[i].t*2;
}
printf("%lld",ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  贪心