您的位置:首页 > 运维架构

poj 3258-River Hopscotch

2014-05-24 14:33 253 查看

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end,
L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks,
N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance
Di from the start (0 <
Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in
order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to
M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of
M rocks.

Input
Line 1: Three space-separated integers: L,
N, and M

Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output
Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing
M rocks
Sample Input
25 5 2
2
14
11
21
17

Sample Output
4

Hint
Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
Source
USACO 2006 December Silver

题目大意:牛跳岩石,给出总长度L,牛的个数N和可以去掉的牛的头数M,求去掉M头牛后,最短距离的最大值。
思路:假设mid是最短距离,count记录此时的mid可以去掉的牛的头数,如果比M小就变大mid,如果比M大就变小mid,注意要求最大值所以等于的时候变大mid。
代码:
import java.util.*;

public class Main {
public static void main(String[] args) {

Scanner scan=new Scanner(System.in);

int L,n,m;

L=scan.nextInt();

n=scan.nextInt();

m=scan.nextInt();

int a[]=new int[n+2];

a[0]=0;

a[n+1]=L;

int l=0,r=L;

for(int i=1;i<=n;i++){

a[i]=scan.nextInt();

}

Arrays.sort(a,0,n+2);

for(int i=1;i<=n+1;i++){

if(l>a[i]-a[i-1])

l=a[i]-a[i-1];

}

while(l<=r){

int mid=(l+r)/2;

int sum=0;

int count=0;

for(int i=1;i<=n+1;i++){

sum+=a[i]-a[i-1];

if(sum<=mid){

count++;

}

else{

sum=0;

}

}

if(count<=m){

l=mid+1;

}

else

r=mid-1;

}

System.out.println(l);

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: