您的位置:首页 > 编程语言 > C语言/C++

POJ Java vs C++

2014-05-24 11:16 323 查看
Java vs C++

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 7179Accepted: 2052
Description

Apologists of Java and C++ can argue for hours proving each other that their programming language is the best one. Java people will tell that their programs are clearer and less prone to errors, while C++ people will laugh at their inability to instantiate
an array of generics or tell them that their programs are slow and have long source code.

Another issue that Java and C++ people could never agree on is identifier naming. In Java a multiword identifier is constructed in the following manner: the first word is written starting from the small letter, and the following ones are written starting
from the capital letter, no separators are used. All other letters are small. Examples of a Java identifier are
javaIdentifier
,
longAndMnemonicIdentifier
,
name
,
nEERC
.

Unlike them, C++ people use only small letters in their identifiers. To separate words they use underscore character ‘
_
’. Examples of C++ identifiers are
c_identifier
,
long_and_mnemonic_identifier
,
name
(you
see that when there is just one word Java and C++ people agree),
n_e_e_r_c
.

You are writing a translator that is intended to translate C++ programs to Java and vice versa. Of course, identifiers in the translated program must be formatted due to its language rules — otherwise people will never like your translator.

The first thing you would like to write is an identifier translation routine. Given an identifier, it would detect whether it is Java identifier or C++ identifier and translate it to another dialect. If it is neither, then your routine should report an error.
Translation must preserve the order of words and must only change the case of letters and/or add/remove underscores.

Input

The input file consists of one line that contains an identifier. It consists of letters of the English alphabet and underscores. Its length does not exceed 100.

Output

If the input identifier is Java identifier, output its C++ version. If it is C++ identifier, output its Java version. If it is none, output “
Error!
instead.

Sample Input
sample input #1
long_and_mnemonic_identifier

sample input #2
anotherExample

sample input #3
i

sample input #4
bad_Style

Sample Output
sample output #1
longAndMnemonicIdentifier

sample output #2
another_example

sample output #3
i

sample output #4
Error!

题解:改为c只要将java中的大写字母前加下划线,及将大写字母改为小写。

      java将c的下划线去掉,将下划线后的字母改为大写。

      如果是ERROR 首字母不能为大写,下划线,不能有2个下划线同时,末尾不能出现下划线

      java没有下划线,c++没有大写字母。

#include <iostream>
#include <string>
#include <cstdio>
using namespace std;
int main()
{
	string s;
	int flag, i;
	while(cin>>s)
	{
		flag =0;
       for(i=0; i<s.length(); i++)
	   {
          if(s[i]=='_')
		  {
			  if(i==0 || s[i-1]=='_' || flag==2|| i==s.length()-1)
			  {
				  flag=3;
				  break;
			  }
               flag=1;
		  }
		  if(s[i]>='A' && s[i]<='Z')
		  {
               if(i==0 || flag==1)
			   {
				   flag=3;
				   break;
			   }
			   flag=2;
		  }
	}
	   if(flag==3)
	   {
		   cout<<"Error!"<<endl;
		   continue;
	   }
	   switch(flag)
	   {
	   case 0:cout<<s<<endl;break;	 
	   case 1:
		   for(i=0; i<s.length(); i++)
		   {
			   
			   if(i>0 && s[i-1]=='_')
			   {
                   cout<<char(s[i]-32);
			   }else if(s[i]!='_')
				   cout<<s[i];
		   }
		   cout<<endl;break;
	   case 2:
		   for(i=0;i<s.length(); i++)
		   {
			   if(s[i]>='a' && s[i]<='z')
				   cout<<s[i];
			   else
			   {
				   cout<<"_";
				   cout<<char(s[i]+32);
			   }
		   }
		   cout<<endl;break;

	 default:break;
	   }
 }
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: