您的位置:首页 > 其它

HDU 1080 Human Gene Functions (DP,最长公共子序列)

2014-05-23 17:18 288 查看


Problem A


Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)


Total Submission(s) : 7 Accepted Submission(s) : 4


Problem Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because
these can be used to diagnose human diseases and to design new drugs for them. A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next
job is to determine its function. One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene
sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet. A database search will return a list of gene sequences from the database that are similar
to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series
of biological experiments will be needed. Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. Given two genes
AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score the resulting
genes according to a scoring matrix. For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These
two strings are aligned: AGTGAT-G -GT--TAG In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring
matrix.
* denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. Of course, many other alignments are possible. One is shown below (a different
number of spaces are inserted into different positions): AGTGATG -GTTA-G This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a
higher score. So, it is said that the similarity of the two genes is 14.



Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence
is at least one and does not exceed 100.



Output

The output should print the similarity of each test case, one per line.



Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA




Sample Output

14 
21



#include<iostream>
#include<cstring>
#include<map>
#include<cmath>
using namespace std;
const int MAXN=105;
int a[MAXN],b[MAXN];
int f[MAXN][MAXN];
inline int MAX(int x,int y){return x<y?y:x;}
const int w[5][5]=
    {{5,-1,-2,-1,-3},
    {-1,5,-3,-2,-4},
    {-2,-3,5,-2,-2},
    {-1,-2,-2,5,-1},
    {-3,-4,-2,-1,0}};
int main()
{
	//freopen("123.txt","r",stdin);
	map<char,int>index;
	index['A']=0;index['C']=1;index['G']=2;index['T']=3;index['-']=4;
	int N,n,m,i,j;
	scanf("%d",&N);
	while(N--)
	{
		scanf("%d ",&n);
		for(i=1;i<=n;i++)
			scanf("%c",&a[i]);
		
		scanf("%d ",&m);
		for(i=1;i<=m;i++)
			scanf("%c",&b[i]);
		
		for(i=1;i<=n;++i)
            f[i][0]=f[i-1][0]+w[index[a[i]]][4];
        for(j=1;j<=m;++j)
            f[0][j]=f[0][j-1]+w[4][index[b[j]]];
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
			{
				int x=index[a[i]];
				int y=index[b[j]];
				f[i][j]=MAX(f[i-1][j-1]+w[x][y],MAX(f[i-1][j]+w[x][4],f[i][j-1]+w[4][y]));
			}
		printf("%d\n",f
[m]);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: