您的位置:首页 > 其它

poj1328--Radar Installation

2014-05-23 10:12 351 查看
Radar Installation

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 49680 Accepted: 11104
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the
sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 


 

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing
two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output
Case 1: 2
Case 2: 1

Source

Beijing 2002

小贪心,由左向右遍历一次,对每一个点找出对应的右侧的圆心,由左向右,确定圆心后,判断之后的点会不会包含在已经确定的圆中

#include <stdio.h>
#include <math.h>
#include <algorithm>
using namespace std;
struct node
{
int x , y ;
double s ;
} p[2000];
bool cmp(node a,node b)
{
return a.s < b.s ;
}
int main()
{
int n , b , i , k = 0 ;
while(scanf("%d %d", &n, &b)!=EOF)
{
if(n == 0 && b == 0)
break;
int num = 0 ;
double x  ;
k++ ;
int flag = 1 ;
for(i = 0 ; i < n ; i++)
{
scanf("%d %d", &p[i].x, &p[i].y);
if(p[i].y  > b)
flag = 0 ;
else
p[i].s = p[i].x * 1.0 + sqrt(b*b*1.0 - p[i].y *p[i].y *1.0) ;
}
if(flag == 0)
{
printf("Case %d: -1\n", k);
continue ;
}
sort(p,p+n,cmp);
x = p[0].s ;
num = 1 ;
for(i = 1 ; i < n ; i ++)
{
if( sqrt( p[i].y*p[i].y*1.0 + (x-p[i].x) * (x-p[i].x) *1.0 ) > b )
{
num++ ;
x = p[i].s ;
}
}
printf("Case %d: %d\n", k, num);
}
return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: