您的位置:首页 > 其它

Oulipo - POJ 3461 KMP

2014-05-22 19:00 375 查看
Oulipo

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 21521Accepted: 8587
Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program
that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T,
count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
***ERDXIVYERDIAN

Sample Output
1
3
0


题意:在第二个字符串中找到第一个字符串出现的次数。

思路:KMP

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
char str1[1000010];
char str2[10010];
int f[10010];
int n,m,ans;
void find()
{ int i,j=0;
  for(i=0;i<n;i++)
  { while(j && str2[j]!=str1[i])
     j=f[j];
    if(str2[j]==str1[i])
     j++;
    if(j==m)
     ans++;
  }
}
void getfail()
{ int i,j;
  memset(f,0,sizeof(f));
  for(i=1;i<m;i++)
  { j=f[i];
    while(j && str2[j]!=str2[i])
     j=f[j];
    if(str2[j]==str2[i])
     f[i+1]=j+1;
    else
     f[i+1]=0;
  }
}
int main()
{ int t,i,j,k;
  scanf("%d",&t);
  while(t--)
  { scanf("%s",str2);
    scanf("%s",str1);
    n=strlen(str1);
    m=strlen(str2);
    ans=0;
    getfail();
    find();
    printf("%d\n",ans);
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: