您的位置:首页 > 其它

Power Strings - POJ 2406 KMP

2014-05-22 18:59 260 查看
Power Strings

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 30578Accepted: 12755
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3


题意:输出整个字符串的最长循环次数。

思路:KMP。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char str[1000010];
int f[1000010];
int n;
void getfail()
{ int i,j;
  memset(f,0,sizeof(f));
  for(i=1;i<=n;i++)
  { j=f[i];
    while(j && str[i]!=str[j])
     j=f[j];
    if(str[i]==str[j])
     f[i+1]=j+1;
    else
     f[i+1]=0;
  }
}
int main()
{ int i,j,k,ans;
  while(~scanf("%s",str)&& str[0]!='.')
  { n=strlen(str);
    getfail();
    ans=1;
    if(n%(n-f
)==0)
      ans=n/(n-f
);
    printf("%d\n",ans);
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: