您的位置:首页 > 其它

POJ 3176-Cow Bowling (简单DP)

2014-05-21 20:58 351 查看
Description
The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

7

3   8

8   1   0

2   7   4   4

4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest
score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.
Input
Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
Output
Line 1: The largest sum achievable using the traversal rules
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30

Hint
Explanation of the sample:

7

*

3   8

*

8   1   0

*

2   7   4   4

*

4   5   2   6   5

The highest score is achievable by traversing the cows as shown above.
 
要求找出和最大, 上一行只能和下一行临近的左边和右边相加 ~

做的第一道DP, 折腾了挺长时间, 乱七八糟的想了一大堆绕远了~

列出表格即可, 有两种方法: 从底到顶 , 从顶到底~

1. 从顶到底, 比较繁琐, 到最后还要在最后一行取最大值..

7                               7

3 8                           10 15

8 1 0                        18 16 15

2 7 4 4                     25 23 20 19

4 5 2 6 5                  29 30 25 26 24

数表格                      和表格

在列出表格的时候就可以慢慢的发现规律, 得到状态方程~

CODE:

#include <iostream>
#include<stdio.h>
#include<math.h>
using namespace std;

int main()
{
//freopen("in.in","r",stdin);
int dp[355][355];
int num[355][355];
int n;
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++)
{
for(int j=0;j<=i;j++)
scanf("%d",&num[i][j]);
}
dp[0][0]=num[0][0];
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
if(j!=0)
dp[i+1][j]=max(dp[i][j],dp[i][j-1])+num[i+1][j];
if(j==0)
dp[i+1][j]=dp[i][j]+num[i+1][j];
}
}
int maxn=dp
[0];
for(int i=1;i<n;i++)
{
if(maxn<dp
[i]) maxn=dp
[i];
}
printf("%d\n",maxn);
}
return 0;
}


2 从底到顶, 计算到顶部是也就得到了最大值, 也想前边一样列表可发现规律~

CODE:

#include <iostream>
#include<stdio.h>
#include<math.h>
using namespace std;

int main()
{
//freopen("in.in","r",stdin);
int dp[355][355];
int num[355][355];
int n;
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++)
{
for(int j=0;j<=i;j++)
scanf("%d",&num[i][j]);
}
for(int i=0;i<n;i++)
dp[n-1][i]=num[n-1][i];
for(int i=n-2;i>=0;i--)
{
for(int j=0;j<n;j++)
{
dp[i][j]=max(dp[i+1][j],dp[i+1][j+1])+num[i][j];
}
}
printf("%d\n",dp[0][0]);
}
return 0;
}


14-8-5 如今再次做这道题又有新的切入点,以每一个三角形中的值作为基准点,选择上面的路线,求出最大值~
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  DP POJ