您的位置:首页 > 产品设计 > UI/UE

Quicksum

2014-05-21 12:52 106 查看

Quicksum

时间限制(普通/Java):1000MS/3000MS 运行内存限制:65536KByte

总提交:602 测试通过:247

描述
A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often
used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and
letters can occur in any combination, including consecutive spaces.

A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So,
A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":

ACM: 1*1 + 2*3 + 3*13 = 46

MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

输入
The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and
contains from 1 to 255 characters.

输出
For each packet, output its Quicksum on a separate line in the output.

样例输入
ACM

MID CENTRAL

REGIONAL PROGRAMMING CONTEST

ACN

A C M

ABC

BBC

#
样例输出
46

650

4690

49

75

14

15
提示

题目来源
Mid-Central USA Region 2006

分析:easy game.But 如果用string的话,不行。因为string不能输入空格,所以只能用char型数组。用gets。

#include<iostream>
using namespace std;

//Quicksum

int main()
{
char s[256];
while(gets(s) && s[0] != '#')
{
int sum = 0;
for(int i=0;s[i] != NULL;i++)
{
if(s[i] != ' ')
sum += (i+1) * (s[i] - 'A' + 1);
}
cout<<sum<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: