您的位置:首页 > 其它

HDU 1010 Tempter of the Bone

2014-05-21 10:58 337 查看


Tempter of the Bone

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the
T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for
more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the
maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;

'S': the start point of the doggie;

'D': the Door; or

'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0


Sample Output

NO
YES


Author

ZHANG, Zheng

Source

ZJCPC2004

题目大意:

给定N*M一张图,问你从起点S到终点D不经过障碍物X恰好K步能否到达?

解题思路:

利用回溯法搜索1条路径即可。

但是注意剪枝

(1)如果剩余的步数小于当前位置到终点的绝对距离,肯定不可行

(2)如果剩余的步数相比到终点的位置的绝对距离为奇数,肯定也不可行

解题代码:

#include <iostream>
#include <string>
#include <cmath>
#include <cstdio>
using namespace std;

const int offx[]={0,1,0,-1};
const int offy[]={1,0,-1,0};

int n,m,t;
char str[10][10];
int sx,sy,dx,dy;

void input(){
for(int i=0;i<n;i++) scanf("%s",&str[i]);
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
if(str[i][j]=='S'){
sx=i,sy=j;
}
if(str[i][j]=='D'){
dx=i,dy=j;
}
}
}
}

bool dfs(int x,int y,int step){
int dist=step-abs(x-dx)+abs(y-dy);
if( dist<0 || (dist&1)  ) return false; //此处剪枝,如果距离小于0或者距离重点的步数为基数。
if(step<=0){
if(abs(x-dx)+abs(y-dy)==0) return true;
else return false;
}
for(int i=0;i<4;i++){
int x0=x+offx[i],y0=y+offy[i];
if(x0<0||x0>=n||y0<0||y0>=m) continue;
if(str[x0][y0]=='X' || str[x0][y0]=='S' || (step>1&&str[x0][y0]=='D') ) continue;
str[x0][y0]='X';
if(dfs(x0,y0,step-1) ) return true;
str[x0][y0]='.';
}
return false;
}

void solve(){
if(dfs(sx,sy,t)) cout<<"YES"<<endl;
else cout<<"NO"<<endl;
}

int main(){
while( scanf("%d%d%d",&n,&m,&t)!=EOF && (m||n||t)){
input();
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: