您的位置:首页 > 其它

hdu1059 Dividing 多重背包

2014-05-21 10:10 351 查看


Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15821    Accepted Submission(s): 4395


Problem Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in
half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the
same total value. 

Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets
of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

 

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2
0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

 

Output

For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.

 

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

 

题意 : 按顺序读入一些列数,所对应的序列代表价值,数值代表个数(如a[5]=6 ,代表价值为五的钻石6个 ), 通过计算判断这些钻石能否被平均分成二等分;w[i]=v[i]'
多重背包;
#include<iostream>
#include<cstring>
#include<algorithm>
#include<iomanip>
using namespace std;
#define N 120002
int dp
,v
,w
,c
,Value
,size
;
int main()
{
int sum,i,j,t=0;
while(true)
{
t++;
sum=0;
for(i=1;i<=6;++i)
{
cin>>c[i];
sum+=i*c[i];
v[i]=i;
w[i]=v[i];
}
if(sum==0)
break;
cout<<"Collection #"<<t<<":"<<endl;
if(sum%2!=0)
{
cout<<"Can't be divided."<<endl<<endl;
continue;
}

int count,Limit;
count=1;
Limit=sum/2;
for(i=1;i<=6;i++)
{
//对该种类的c[i]件物品进行二进制分解
for(j=1;j<=c[i];j<<=1)
{
//<<右移1位,相当于乘2
Value[count]=j*v[i];
size[count++]=j*w[i];
c[i] -= j;
}
if(c[i] > 0)
{
Value[count]=c[i]*v[i];
size[count++]=c[i]*w[i];
}
}
memset(dp,0,sizeof(dp));
for(i=1;i<count;i++)
for(j=Limit;j>=size[i];j--)
if(dp[j] < dp[j-size[i]] + Value[i])
dp[j]=dp[j-size[i]]+Value[i];

//cout<<dp[Limit]<<endl;
if(dp[Limit]==Limit)
cout<<"Can be divided."<<endl<<endl;
else
cout<<"Can't be divided."<<endl<<endl;

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: