您的位置:首页 > 其它

Crazy Search - POJ 1200 哈希

2014-05-20 18:03 323 查看
Crazy Search

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 21981Accepted: 6194
Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon
will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.

Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5.

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed
16 Millions.
Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
Sample Input
3 4
daababac

Sample Output
5


题意:给你n和nc,让你把所有n位的字母转换成nc进制的数,问这些数有多少个(不能重复)。

思路:分配值后哈希(其实也不能叫哈希,就是转换进制吧)。

AC代码如下:

#include <iostream>
#include <string>
#include <cstdio>
using namespace std;
#define N 16000000
string str;
bool hash
;
int cha[500];
int main()
{ int n,nc,ans=0,sum,k=0;
  scanf("%d%d",&n,&nc);
   cin>>str;
  for(int i=0;i<str.length();i++)
  { if(cha[str[i]]==0)
     cha[str[i]]=++k;
    if(k==nc) break;
  }
  for(int i=0;i<str.length()-n+1;i++)
  { sum=0;
    for(int j=i;j<i+n;j++)
     sum=(sum*nc+cha[str[j]]);
    if(!hash[sum])
    { hash[sum]=true;
      ans++;
    }
  }
  printf("%d\n",ans);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: