您的位置:首页 > 其它

Doubles - POJ 1552 水题

2014-05-20 17:56 344 查看
Doubles

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 18799Accepted: 10840
Description

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program
to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

1 4 3 2 9 7 18 22


your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input

The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not
considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.
Output

The output will consist of one line per input list, containing a count of the items that are double some other item.
Sample Input
1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output
3
2
0


题意:找到有多少组数是一个是另一个的二倍。

思路:暴力枚举即可。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
bool cmp(int a,int b)
{ return a>b;
}
int num[1010];
char s[10000010];
char c,d;
int main()
{ int t,i,j,k,pos,ans,ret;
  c='a';
  pos=0;
  ans=0;
  while(~scanf("%d%c",&num[++pos],&c) && num[1]!=-1)
  { while(c!='\n')
    { scanf("%d",&num[++pos]);
      scanf("%c",&c);
    }
    sort(num+1,num+1+pos,cmp);
    for(i=1;i<pos;i++)
    { for(j=i+1;j<=pos;j++)
       if(num[j]*2==num[i])
        ans++;
    }
    printf("%d\n",ans);
    pos=0;
    ans=0;
    c='a';
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: