您的位置:首页 > 其它

hdu 1690 Bus System (最短路径)

2014-05-17 08:28 447 查看

Bus System

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6082 Accepted Submission(s): 1560


[align=left]Problem Description[/align]
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.

[align=left]Input[/align]
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.

[align=left]Output[/align]
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.

[align=left]Sample Input[/align]

2
1 2 3 4 1 3 5 7

4 2
1
2
3
4

1 4

4 1
1 2 3 4 1 3 5 7
4 1
1
2
3
10

1 4

[align=left]Sample Output[/align]

Case 1:

The minimum cost between station 1 and station 4 is 3.
The minimum cost between station 4 and station 1 is 3.

Case 2:

Station 1 and station 4 are not attainable.

[align=left]Source[/align]
2008 “Sunline Cup” National Invitational Contest

[align=left]Recommend[/align]
wangye | We have carefully selected several similar problems for you: 2722 1689 2433 2482 2923

简单最短路径,注意是64位:

//125MS     288K    1415B     G++
#include<stdio.h>
#include<string.h>
#define N 105
#define inf 1000000000000LL
__int64 g

;
int n,m;
__int64 abs(__int64 a)
{
return a<0?-a:a;
}
__int64 Min(__int64 a,__int64 b)
{
return a<b?a:b;
}
void floyd() //弗洛伊德算法
{
for(int k=0;k<n;k++)
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
g[i][j]=Min(g[i][j],g[i][k]+g[k][j]);
}
int main(void)
{
int t,k=1;
__int64 l1,l2,l3,l4,c1,c2,c3,c4,x
;
int a,b;
scanf("%d",&t);
while(t--)
{
scanf("%I64d%I64d%I64d%I64d%I64d%I64d%I64d%I64d",&l1,&l2,&l3,&l4,&c1,&c2,&c3,&c4);
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++) scanf("%I64d",&x[i]);
for(int i=0;i<n;i++)
for(int j=0;j<n;j++){
int L=abs(x[i]-x[j]);
if(L==0) g[i][j]=0;
else if(L<=l1) g[i][j]=c1;
else if(L<=l2) g[i][j]=c2;
else if(L<=l3) g[i][j]=c3;
else if(L<=l4) g[i][j]=c4;
else g[i][j]=inf;
}
floyd();
printf("Case %d:\n",k++);
while(m--){
scanf("%d%d",&a,&b);
if(g[a-1][b-1]==inf) printf("Station %d and station %d are not attainable.\n",a,b);
else printf("The minimum cost between station %d and station %d is %I64d.\n",a,b,g[a-1][b-1]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: