您的位置:首页 > 其它

hdu 2955 Robberies

2014-05-16 22:02 134 查看
[align=left]Problem Description[/align]
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative
business of bank robbery only for a short while, before retiring to a comfortable job at a university.



For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

[align=left]Input[/align]
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of
banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

[align=left]Output[/align]
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

[align=left]Sample Input[/align]

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05


[align=left]Sample Output[/align]

2
4
6这道题应该将钱数当背包容量,将概率当价值。因为概率是实型的,把思维转换过来就行了。加一个理解的代码:[code]#include<stdio.h>
#include<math.h>
#include<string.h>
#define MAX(a,b) (a>b?a:b)
int main()
{
int T, i, j, n, M[110];
float P, p[110], dp[10010];//用float 类型就行了, 用double 类型会导致数据缺失。
scanf("%d",&T);
while(T--)
{
memset(dp,0,sizeof(dp));//要对数组进行初始化
int sum = 0;
scanf("%f%d",&P,&n);
P = 1 - P;//成功逃走的概率
for(i = 1; i <= n; i++)
{
scanf("%d%f",&M[i],&p[i]);
sum += M[i];//算出银行总钱数
p[i] = (1 - p[i]);
}
dp[0] = 1;//未抢劫一分钱那么逃走的概率就为1
for(i = 1; i <= n; i++)
{
for(j = sum; j >= M[i]; j--)
{
dp[j] = MAX(dp[j],dp[j - M[i]] * p[i]);//这里的每次成功的概率需要进行乘法运算,因为是两次成功的概率所以是乘法
}
}
for(i = sum; i >= 0; i--)
{
if(dp[i] >= P)
{
break;//找出可以成功逃走并且逃走概率不超过警戒值
}
}
printf("%d\n",i);
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: