您的位置:首页 > 其它

hdu 1142 A Walk Through the Forest (最短路径)

2014-05-16 13:16 549 查看

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5306 Accepted Submission(s): 1939


[align=left]Problem Description[/align]
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.

[align=left]Input[/align]
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.

[align=left]Output[/align]
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647

[align=left]Sample Input[/align]

5 6
1 3 2

1 4 2

3 4 3
1 5 12

4 2 34

5 2 24
7 8
1 3 1
1 4 1

3 7 1
7 4 1
7 5 1
6 7 1
5 2 1

6 2 1

0

[align=left]Sample Output[/align]

2

4

[align=left]Source[/align]
University of Waterloo Local Contest 2005.09.24

[align=left]Recommend[/align]
Eddy | We have carefully selected several similar problems for you: 2722 2962 2923 1116 2433

开始题意理解错了,以为求最短路径的数目。其实求的是在点1到点2的路径中,经过的路段Vij要求d[i]>d[j](d[i]为点i到到点2的最短路),求满足要求的路径数。

最短路径:

先求出点2到其他店的最短路,然后记忆化搜索得解。

//31MS     820K    1533B     G++
#include<iostream>
#include<vector>
#include<queue>
#define N 1005
#define inf 0x7fffffff
using namespace std;
struct node{
int v,d;
node(int a,int b){
v=a;d=b;
}
};
vector<node>V
;
int vis
,d
;
int v;
int n,m;
int ans
;
void dij(int s)
{
memset(vis,0,sizeof(vis));
for(int i=0;i<=n;i++)
d[i]=inf;
d[s]=0;
queue<int>Q;
Q.push(s);
vis[s]=1;
while(!Q.empty()){
int u=Q.front();
Q.pop();
vis[u]=0;
int m=V[u].size();
for(int i=0;i<m;i++){
int v=V[u][i].v;
int w=V[u][i].d;
if(d[v]>d[u]+w){
d[v]=d[u]+w;
if(!vis[v]){
vis[v]=1;
Q.push(v);
}
}
}
}
}
int dfs(int u)
{
if(u==2) return 1;
if(ans[u]!=0) return ans[u];
int m=V[u].size();
int cnt=0;
for(int i=0;i<m;i++){
int v=V[u][i].v;
int w=V[u][i].d;
if(d[v]<d[u])
cnt+=dfs(v);
}
return ans[u]=cnt;
}
int main(void)
{
int a,b,c;
while(scanf("%d",&n),n)
{
scanf("%d",&m);
memset(ans,0,sizeof(ans));
for(int i=0;i<=n;i++) V[i].clear();
for(int i=0;i<m;i++){
scanf("%d%d%d",&a,&b,&c);
V[a].push_back(node(b,c));
V[b].push_back(node(a,c));
}
dij(2);
printf("%d\n",dfs(1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: