您的位置:首页 > 其它

HDOJ 1003 Max Sum

2014-05-15 20:35 288 查看


Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 136547 Accepted Submission(s): 31609



Problem Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


Sample Output

Case 1:
14 1 4

Case 2:
7 1 6思路:简单动态规划#include<iostream>
using namespace std;
int main()
{
int temp,now,max,x,pos1,pos2;
int n,t,i,j;
cin>>n;
for(j=0;j<n;j++)
{
cin>>t>>temp;
now=max=temp;
pos1=pos2=x=1;
for(i=2;i<=t;i++)
{
cin>>temp;
if(now+temp<temp)
{
now=temp;
x=i;
}
else
now+=temp;
if(now>max)
{
max=now;
pos1=x;pos2=i;
}
}
cout<<"Case "<<j+1<<':'<<endl;
cout<<max<<" "<<pos1<<" "<<pos2<<endl;
if(j+1==n)
break;
cout<<endl;
}
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: