您的位置:首页 > 其它

poj 3295 Tautology

2014-05-15 16:06 447 查看
Tautology

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9053 Accepted: 3463
Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

p, q, r, s, and t are WFFs
if w is a WFF, Nw is a WFF
if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.

The meaning of a WFF is defined as follows:
p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.

Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1
A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the
value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input
ApNp
ApNq
0

Sample Output
tautology
not

Source

Waterloo Local Contest, 2006.9.30

K是&&

A是||

N是!

C是!w||x

E是w==x

给出一个式子判断一下这个式子是不是永真式

直接把五种条件分别走一遍1和0 就行了 2^5*100 绝对不超时

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <ctype.h>
#include <iostream>
#include <algorithm>
#include <map>
#include <string>
#include <vector>

using namespace std;

char str[101];
int len;

int Find()
{
int BOOL[101];
for(int P=0; P<=1; P++)
{
for(int Q=0; Q<=1; Q++)
{
for(int R=0; R<=1; R++)
{
for(int S=0; S<=1; S++)
{
for(int T=0; T<=1; T++)
{
int top=0;
for(int i=len-1; i>=0; i--)
{
if(str[i]=='p')
BOOL[top++]=P;
else if(str[i]=='q')
BOOL[top++]=Q;
else if(str[i]=='r')
BOOL[top++]=R;
else if(str[i]=='s')
BOOL[top++]=S;
else if(str[i]=='t')
BOOL[top++]=T;
else if(str[i]=='K')
{
top--;
BOOL[top-1]=(BOOL[top-1]&&BOOL[top]);
}
else if(str[i]=='A')
{
top--;
BOOL[top-1]=(BOOL[top-1]||BOOL[top]);
}
else if(str[i]=='N')
{
BOOL[top-1]=!BOOL[top-1];
}
else if(str[i]=='C')
{
top--;
BOOL[top-1]=(!BOOL[top-1]||BOOL[top]);
}
else if(str[i]=='E')
{
top--;
BOOL[top-1]=(BOOL[top-1]==BOOL[top]);
}
}
if(top!=1||BOOL[top-1]!=1)
return 0;
}
}
}
}
}
return 1;
}

int main()
{
while(cin>>str)
{
if(str[0]=='0')
break;
len=strlen(str);
int flag=Find();
if(flag)
cout<<"tautology"<<endl;
else
cout<<"not"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: