您的位置:首页 > 其它

Rank List - POJ 2153 map

2014-05-15 16:02 155 查看
Rank List

Time Limit: 10000MSMemory Limit: 65536K
Total Submissions: 9119Accepted: 3018
Description

Li Ming is a good student. He always asks the teacher about his rank in his class after every exam, which makes the teacher very tired. So the teacher gives him the scores of all the student in his class and asked him to get his rank by himself. However, he
has so many classmates, and he can’t know his rank easily. So he tends to you for help, can you help him?
Input

The first line of the input contains an integer N (1 <= N <= 10000), which represents the number of student in Li Ming’s class. Then come N lines. Each line contains a name, which has no more than 30 letters. These names represent all the students in Li Ming’s
class and you can assume that the names are different from each other.

In (N+2)-th line, you'll get an integer M (1 <= M <= 50), which represents the number of exams. The following M parts each represent an exam. Each exam has N lines. In each line, there is a positive integer S, which is no more then 100, and a name P, which
must occur in the name list described above. It means that in this exam student P gains S scores. It’s confirmed that all the names in the name list will appear in an exam.

Output

The output contains M lines. In the i-th line, you should give the rank of Li Ming after the i-th exam. The rank is decided by the total scores. If Li Ming has the same score with others, he will always in front of others in the rank list.
Sample Input
3
Li Ming
A
B
2
49 Li Ming
49 A
48 B
80 A
85 B
83 Li Ming

Sample Output
1
2


题意:简单的map题,问你李明排第多少名,注意后面的排名也要算上前面的成绩。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<map>
#include<string>
#include<iostream>
#include<set>
using namespace std;

map <string,int>match;
map <string,int>::iterator it;
char s[1010];
int main()
{ int t,n,m,i,j,k,num=1;
  scanf("%d",&n);
  getchar();
  for(i=1;i<=n;i++)
  { gets(s);
    match[s]=0;
  }
  scanf("%d",&t);
  while(t--)
  { num=1;
  for(i=1;i<=n;i++)
  { scanf("%d",&k);
    getchar();
    gets(s);
    match[s]+=k;
  }
  for(it=match.begin();it!=match.end();it++)
  { if(it->second>match["Li Ming"])
     num++;
  }
  printf("%d\n",num);
 }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: