您的位置:首页 > 其它

【UvaOJ】【基础题目】【Maths - Number Theory】 10110 - Light, more light

2014-05-14 17:49 423 查看
Light, more light

The Problem

There is man named "mabu" for switching on-off light in our University. He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another
press will turn it off. To save power consumption (or may be he is mad or something else) he does a peculiar thing. If in a corridor there is `n' bulbs, he walks along the corridor back and forth `n' times and in i'th walk he toggles only the switches whose
serial is divisable by i. He does not press any switch when coming back to his initial position. A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.
Now you have to determine what is the final condition of the last bulb. Is it on or off? 

 

The Input

The input will be an integer indicating the n'th bulb in a corridor. Which is less then or equals 2^32-1. A zero indicates the end of input. You should not process this input.

The Output

Output "yes" if the light is on otherwise "no" , in a single line.

Sample Input

3
6241
8191
0

Sample Output

no
yes
no

——————————————————————————————————
解题思路:

题目大意是,一个走廊上有N个灯泡,有个人第 i 次走过去就按一下能被 i 整除的那个编号的灯泡按钮,返回时不按任何按钮。往返N次以后,问最后一盏灯的状态?

题目问最后一盏灯的状态,实际上就是问从1到N这些数字中,是N的因子的个数,若个数是奇数,那么最后灯亮,若个数是偶数,那么最后一盏灯灭。

!!!
关键点在于:直接遍历N个数字逐一判断是否为N的因子,这个O(N)的方法会超时。
实际上,符合因子个数之和为奇数的的数为完全平方数。

所以只需判断,这个数的平方根取整之后是否就等于其平方根。

————————————————————————————
代码:

#include<iostream>
#include<fstream>
#include<stdlib.h>
#include<cstdio>
#include<cmath>
using namespace std;

int main()
{
long long n;
while (cin >> n)
{
if (n == 0)
break;
if ( (long long)(sqrt(n)) == sqrt(n))
cout << "yes" << endl;
else
cout << "no" << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息