您的位置:首页 > 其它

poj 3624 Charm Bracelet(01背包)

2014-05-13 20:50 453 查看
Charm Bracelet

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 20946Accepted: 9470
链接:poj 3624

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in
the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight
is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input
4 6
1 4
2 6
3 12
2 7


Sample Output
23


Source

USACO 2007 December Silver

题意:有n个手链,第i个手链的重量为Wi,价值为Di,每个手链最多能选一次,背包的总重量为M,求最大价值。

AC代码:
#include<stdio.h>
#include<string.h>
struct stu{
    int w,d;
}s[3500];
int main()
{
    int i,j,k,n,m,a[13000];
    scanf("%d%d",&n,&m);
    for(i=1;i<=n;i++)
        scanf("%d%d",&s[i].w,&s[i].d);
    memset(a,0,sizeof(a));
    for(i=1;i<=n;i++)
        for(j=m;j>=s[i].w;j--){
            k=a[j-s[i].w]+s[i].d;
            if(k>a[j])
                a[j]=k;
        }
    printf("%d\n",a[m]);
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: