您的位置:首页 > 其它

POJ1269_Intersecting Lines(计算几何/两直线位置关系模板)

2014-05-13 17:52 429 查看
Intersecting Lines

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10052 Accepted: 4500
Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they
are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 

Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4.
Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).
Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point.
If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".
Sample Input
5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output
INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

Source

解题报告

判断两个直线的平面关系。。。

先判断两条直线是不是同线,不是的话再判断是否平行,再不是的话就只能是相交的,求出交点。

同线的话就是任意两次的三点共线。。。

平行就直接判断两向量平行。。。

求交点是连立两直线方程。。。

这题要用%.2f输出,不能%lf输出。。。坑

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>

using namespace std;
struct point
{
double x,y;
} p1,p2,v1,v2,p;
int Collinear3(point a,point b,point c)//三点共线(向量ab和向量ac共线)
{
//向量ab=(b.x-a.x,b.y-a.y)
//向量ac=(c.x-a.x,c.y-a.y)
//两向量共线: ab X ac = 0
if((b.x-a.x)*(c.y-a.y)-(b.y-a.y)*(c.x-a.x)==0)
return 1;
return 0;
}
int Parallel(point p1,point p2,point v1,point v2)//两直线平行
{
if((p2.y-p1.y)*(v2.x-v1.x)-(v2.y-v1.y)*(p2.x-p1.x)==0)
return 1;
return 0;
}
point intersection(point p1,point p2,point v1,point v2)//两直线交点
{
point p=p1;
double k=((p1.x-v1.x)*(v1.y-v2.y)-(p1.y-v1.y)*(v1.x-v2.x))/((p1.x-p2.x)*(v1.y-v2.y)-(p1.y-p2.y)*(v1.x-v2.x));
p.x+=(p2.x-p1.x)*k;
p.y+=(p2.y-p1.y)*k;
return p;
}
int main()
{
int t;
cin>>t;
cout<<"INTERSECTING LINES OUTPUT"<<endl;
while(t--)
{
cin>>p1.x>>p1.y>>p2.x>>p2.y>>v1.x>>v1.y>>v2.x>>v2.y;
if(Parallel(p1,p2,v1,v2))
{
if(Collinear3(p1,p2,v1)&&Collinear3(p1,p2,v2))
{
cout<<"LINE"<<endl;
}
else cout<<"NONE"<<endl;
}
else
{
p=intersection(p1,p2,v1,v2);
printf("POINT %.2f %.2f\n",p.x,p.y);
}
}
cout<<"END OF OUTPUT"<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: