您的位置:首页 > 其它

poj 1080(动态规划之最长公共之序列)

2014-05-12 09:36 531 查看
Human Gene Functions

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 16652Accepted: 9238
Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because
these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.

One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many
researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene.

Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments
will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity

of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of

the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal

length. These two strings are aligned:

AGTGAT-G

-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.



denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG

-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the

similarity of the two genes is 14.
Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence
is at least one and does not exceed 100.
Output

The output should print the similarity of each test case, one per line.
Sample Input
2
7 AGTGATG
5 GTTAG
7 AGCTATT
9 AGCTTTAAA

Sample Output
14
21

直接上AC代码:

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int f[110][110];
int map[5][5]={{5,-1,-2,-1,-3},
{-1,5,-3,-2,-4},
{-2,-3,5,-2,-2},
{-1,-2,-2,5,-1},
{-3,-4,-2,-1,0}};
int main(){
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int T;
cin>>T;
while(T--){
int a[110],b[110];
int n,m;
char s1[110],s2[110];       //注意poj里 不能定义为string s; 然后通过s[i]访问单个字符,否则会compile error
cin>>n>>s1>>m>>s2;
for(int i=0;i<n;i++)
if(s1[i]=='A')
a[i+1]=0;
else if(s1[i]=='C')
a[i+1]=1;
else if(s1[i]=='G')
a[i+1]=2;
else
a[i+1]=3;
for(int i=0;i<m;i++)
if(s2[i]=='A')
b[i+1]=0;
else if(s2[i]=='C')
b[i+1]=1;
else if(s2[i]=='G')
b[i+1]=2;
else
b[i+1]=3;
f[0][0]=0;
for(int i=1;i<=n;i++)
f[i][0]=f[i-1][0]+map[a[i]][4];
for(int i=1;i<=m;i++)
f[0][i]=f[0][i-1]+map[4][b[i]];
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
f[i][j]=max(f[i-1][j-1]+map[a[i]][b[j]],max(f[i][j-1]+map[4][b[j]],f[i-1][j]+map[a[i]][4]));
cout<<f
[m]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: