您的位置:首页 > 其它

poj 1007 DNA Sorting

2014-05-11 22:06 274 查看
DNA Sorting

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 80359 Accepted: 32327
Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four
letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions
(it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length.

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string
of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source
East Central North America 1998

简单的算逆序数  再按从大到小一次输出    第一次用结构体。。。。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

struct H
{
int l;
char s[55];
}a[105];

int cmp(H b,H c)
{
return b.l<c.l;
}

int main()
{
int i,j,k,n,m;
while(cin>>n>>m)
{
memset(a,0,sizeof(a));
for(i=0;i<m;i++)
{
scanf("%s",&a[i].s);
//printf("%d\n",a[i].l);
}
for(i=0;i<m;i++)
{
for(k=0;k<n;k++)
{	for(j=k+1;j<n;j++)
{
if(a[i].s[k]>a[i].s[j])
a[i].l++;

}
//cout<<a[i].l<<" ";
}
//cout<<endl;

}
sort(a,a+m,cmp);
for(i=0;i<m;i++)
{
//printf("%d\n",a[i].l);
puts(a[i].s);
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: