您的位置:首页 > 其它

PAT A 1025. PAT Ranking (25)

2014-05-10 12:55 363 查看
题目

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is
your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and
then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4


直接模拟

使用了比较慢,但是比较简单的方法

先对各个考场排序,确定考场排名,再把数据简单地放到一起,再次排序

如果对排序好后的各个考场的数据进行合并然后输出

考场人数分布比较平均的状态下可以从n*log(n)下降到n

代码:

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;

/****************************************************************************************************************
使用了比较慢,但是比较简单的方法
先对各个考场排序,确定考场排名,再把数据简单地放到一起,再次排序

如果对排序好后的各个考场的数据进行合并然后输出
考场人数分布比较平均的状态下可以从n*log(n)下降到n
****************************************************************************************************************/

struct student	//学生
{
string num;		//学号
int score;		//分数
int loc;		//考场
int loc_rank;	//考场排名
};

bool cm(const student &s1,const student &s2);	//排名
void rank_s(vector<student> &stu);	//用于对一个考场中的学生排名

int main()
{
int n,k,total_stu=0,i,j;
student temp_s;
vector<student> stu_total,stu_loc[100];	//总的学生,各个考场
cin>>n;
for(i=0;i<n;i++)	//输入学生数据
{
cin>>k;
total_stu+=k;
for(j=0;j<k;j++)
{
cin>>temp_s.num;
cin>>temp_s.score;
temp_s.loc=i+1;
stu_loc[i].push_back(temp_s);
}
sort(stu_loc[i].begin(),stu_loc[i].end(),cm);
rank_s(stu_loc[i]);	//考场排名
}

for(i=0;i<n;i++)	//单纯地将数据并到一块儿,再整体排序
for(j=0;j<stu_loc[i].size();j++)
stu_total.push_back(stu_loc[i][j]);
sort(stu_total.begin(),stu_total.end(),cm);

cout<<total_stu<<endl;
int score=stu_total[0].score,rank=1;	//暂存数据:记录之前学生的分数(并列的),用于处理并列;记录并列中第一个人的排名
for(i=0;i<total_stu;i++)
{
if(stu_total[i].score<score)	//分数不同,输出,刷新暂存数据
{
cout<<stu_total[i].num<<" ";
cout<<i+1<<" ";
cout<<stu_total[i].loc<<" ";
cout<<stu_total[i].loc_rank<<endl;
score=stu_total[i].score;
rank=i+1;
}
else		//分数相同
{
cout<<stu_total[i].num<<" ";
cout<<rank<<" ";
cout<<stu_total[i].loc<<" ";
cout<<stu_total[i].loc_rank<<endl;
}
}

return 0;
}

bool cm(const student &s1,const student &s2)	//比较,用于排序
{
if(s1.score>s2.score)
return true;
else if(s1.score<s2.score)
return false;
else
return s1.num<s2.num;
}

void rank_s(vector<student> &stu)	//分考场排名
{
int score=stu[0].score,rank=1,i;
for(i=0;i<stu.size();i++)
{
if(stu[i].score<score)
{
stu[i].loc_rank=i+1;
score=stu[i].score;
rank=i+1;
}
else
{
stu[i].loc_rank=rank;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: