您的位置:首页 > 其它

nyoj_308_Substring_201405091611

2014-05-09 17:23 246 查看

Substring

时间限制:1000 ms | 内存限制:65535 KB
难度:1

描述
You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input.

Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

输入The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').输出Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input样例输入
3
ABCABA
XYZ
XCVCX

样例输出
ABA
X
XCVCX

来源第四届河南省程序设计大赛上传者张云聪

#include <stdio.h>
#include <string.h>
int map[60][60];
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int i,j,len,max=0,t;
char str1[60],str2[60];
memset(map,0,sizeof(map));
scanf("%s",str1);
len = strlen(str1);
for(i=0;i<len;i++)
str2[i]=str1[len-1-i];
for(i=0;i<len;i++)
{
for(j=0;j<len;j++)
{
if(str1[i]==str2[j])
map[i+1][j+1] = map[i][j]+1;
if(map[i+1][j+1]>max)
{
max = map[i+1][j+1];
t = i+1;
}
}
}
for(i=t-max;i<t;i++)
printf("%c",str1[i]);
printf("\n");
}
return 0;
}


//最长公共子串

//http://i.cnblogs.com/EditPosts.aspx?postid=3582994
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: