您的位置:首页 > 其它

PAT A 1024. Palindromic Number (25)

2014-05-09 16:32 204 查看
题目

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives
a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by
a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just
output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3


直接模拟,数可能比较大,用string表述即可

代码

#include <iostream>
#include <string>
using namespace std;

bool Is_pal(string s);	//判断是否是Palindromic数
string Pair(string s);	//反转叠加

int main()
{
int k,i;
string s_n;

cin>>s_n>>k;
for(i=0;i<k;i++)
if(Is_pal(s_n))
{
cout<<s_n<<endl<<i;
return 0;
}
else
s_n=Pair(s_n);

cout<<s_n<<endl<<i;

return 0;
}

bool Is_pal(string s)
{
int i;
for(i=0;i<s.size();i++)
if(s[i]!=s[s.size()-1-i])
return false;
return true;
}

string Pair(string s)
{
int i;
char dig;
int carry=0;
string s_rev,s_sum;
for(i=s.size()-1;i>=0;i--)
s_rev+=s[i];
for(i=s.size()-1;i>=0;i--)
{
dig='0'+(s[i]-'0'+s_rev[i]-'0'+carry)%10;
carry=(s[i]-'0'+s_rev[i]-'0'+carry)/10;
s_sum.insert(s_sum.begin(),dig);
}
if(carry==1)
s_sum.insert(s_sum.begin(),'1');
return s_sum;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: