您的位置:首页 > 其它

poj 2752 Seek the Name, Seek the Fame(KMP)

2014-05-08 21:36 369 查看
点击打开题目链接


Seek the Name, Seek the Fame

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11198 Accepted: 5457
Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative
little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings
of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.
Sample Input
ababcababababcabab
aaaaa

Sample Output
2 4 9 18
1 2 3 4 5


题意:给你一个字符串,找出所有的前缀和后缀相等的子串,按小到大输出这些子串的长度,[b]kmp变形[/b]

深刻理解next函数的意义,这题就变得非常简单。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

char s[400005];
int e[400005];

int next[400005];
void getnext(char *s,int *next,int len)
{
int i,j;
next[0]=-1;
i=0;
j=-1;
while(i<len)
{
if(j==-1||s[j]==s[i])
{
i++;
j++;
next[i]=j;
}
else
j=next[j];
}
}
int main()
{
int t,i,j,k,n;
while(~scanf("%s",s))
{
t=strlen(s);
memset(next,0,sizeof(next));
getnext(s,next,t);
e[0]=t;
i=t;n=1;

while(next[i]>0)
{
e[n++]=next[i];
i=next[i];
}
for(i=n-1;i>=0;i--)
{
printf("%d",e[i]);
if(i!=0)
printf(" ");
}
printf("\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: