您的位置:首页 > 大数据 > 人工智能

ZOJ 3780 Paint the Grid Again(topsort)

2014-05-08 21:35 357 查看
ZOJ Problem Set - 3780

Paint the Grid Again

Time Limit: 2 Seconds Memory Limit: 65536 KB

Leo has a grid with N × N cells. He wants to paint each cell with a specific color (either black or white).

Leo has a magical brush which can paint any row with black color, or any column with white color. Each time he uses the brush, the previous color of cells will be covered by the new color. Since the magic of the brush is limited, each row and each column
can only be painted at most once. The cells were painted in some other color (neither black nor white) initially.

Please write a program to find out the way to paint the grid.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 500). Then N lines follow. Each line contains a string with N characters. Each character is either 'X' (black) or 'O' (white) indicates the color of the cells should
be painted to, after Leo finished his painting.

Output

For each test case, output "No solution" if it is impossible to find a way to paint the grid.

Otherwise, output the solution with minimum number of painting operations. Each operation is either "R#" (paint in a row) or "C#" (paint in a column), "#" is the index (1-based) of the row/column. Use exactly one space to separate each operation.

Among all possible solutions, you should choose the lexicographically smallest one. A solution X is lexicographically smaller than Y if there exists an integer k, the first k - 1 operations of X and Y are
the same. The k-th operation of X is smaller than the k-th in Y. The operation in a column is always smaller than the operation in a row. If two operations have the same type, the one with smaller index of row/column is the lexicographically
smaller one.

Sample Input

2
2
XX
OX
2
XO
OX

Sample Output

R2 C1 R1
No solution


Author: YU, Xiaoyao

Source: The 11th Zhejiang Provincial Collegiate Programming Contest

xxxo先涂行,在涂列

x

o

x

x 先涂列在涂行。 因此可以构造一个图,进行topsort。如果要col先可以给col 小的标号,每次用无入度点的最小点。

记住,刚开始的无入度点可以不涂。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <set>
#include <queue>
#include <vector>
#include <algorithm>
#include <map>
#include <stack>
#include <cmath>

#define FOR(i,a,b) for(int i=a;i<=b;++i)
#define DWN(i,a,b) for(int i=a;i>=b;--i)
#define clr(f,z) memset(f,z,sizeof(f))
#define ll(x) (1<<x)
#define PII pair<int,int>
#define PB push_back
#define LL long long

using namespace std;

const int mm = 508;

class Node
{
public:
int v,next;
}e[mm*mm*2];

int head[mm+mm],edge,id[mm+mm];
bool first[mm+mm];
vector<int>ans;
priority_queue<int,vector<int>,greater<int> > Q;

void init()
{
clr(head,-1); edge = 0;
clr(id,0);
clr(first,0);
}

void add(int u,int v)
{
e[edge].v = v; e[edge].next = head[u]; head[u] = edge++;
++id[v];
}
int N;
char s[mm][mm];
bool topsort(int n)
{
for(int i=0;i<n;++i)
if(id[i] == 0)
Q.push(i),first[i] = 1;
int u,v;
while(!Q.empty())
{
u = Q.top();Q.pop();
ans.PB(u);
for(int i=head[u];~i;i=e[i].next)
{
v=e[i].v;
--id[ v ];
if(id[v] == 0)
Q.push(v);
}
}
for(int i=0;i<n;++i)
if(id[i])
return false;
return true;
}
int main()
{
int cas;
while(~scanf("%d",&cas))
{
while(cas--)
{
scanf("%d",&N);
init();
for(int i=0;i<N;++i)
scanf("%s",s[i]);
for(int i=0;i<N;++i)
for(int j=0;j<N;++j)
if(s[i][j] == 'X') //x 先列再行 o 先行再列
add(j,i+N);
else add(i+N,j);
ans.clear();
if(topsort(N+N))
{
int len = ans.size();
for(int i=0;i<len;++i)
if(first[ ans[i] ])
continue;
else if(ans[i]<N)
printf("C%d%c",ans[i]+1,i==len-1?'\n':' ');
else
printf("R%d%c",ans[i]-N+1,i==len-1?'\n':' ');
}
else printf("No solution\n");

}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: