您的位置:首页 > 其它

POJ 1775 sum of Factorial (数论)

2014-05-07 16:39 239 查看
链接:http://poj.org/problem?id=1775

Description

John von Neumann, b. Dec. 28, 1903, d. Feb. 8, 1957, was a Hungarian-American mathematician who made important contributions to the foundations of mathematics, logic, quantum physics,meteorology, science, computers, and game theory. He was noted for a phenomenal
memory and the speed with which he absorbed ideas and solved problems. In 1925 he received a B.S. diploma in chemical engineering from Zurich Institute and in 1926 a Ph.D. in mathematics from the University of Budapest. His Ph.D. dissertation on set theory
was an important contribution to the subject. At the age of 20, von Neumann proposed a new definition of ordinal numbers that was universally adopted. While still in his twenties, he made many contributions in both pure and applied mathematics that established
him as a mathematician of unusual depth. His Mathematical Foundations of Quantum Mechanics (1932) built a solid framework for the new scientific discipline. During this time he also proved the mini-max theorem of GAME THEORY. He gradually expanded his work
in game theory, and with coauthor Oskar Morgenstern he wrote Theory of Games and Economic Behavior (1944). 

There are some numbers which can be expressed by the sum of factorials. For example 9,9=1!+2!+3! Dr. von Neumann was very interested in such numbers. So, he gives you a number n, and wants you to tell him whether or not the number can be expressed by the sum
of some factorials. 

Well, it's just a piece of cake. For a given n, you'll check if there are some xi, and let n equal to Σ1<=i<=txi!. (t >=1 1, xi >= 0, xi = xj iff. i = j). If the answer is yes, say "YES"; otherwise, print out "NO".
Input

You will get several non-negative integer n (n <= 1,000,000) from input file. Each one is in a line by itself. 

The input is terminated by a line with a negative integer.
Output

For each n, you should print exactly one word ("YES" or "NO") in a single line. No extra spaces are allowed.
Sample Input
9
-1

Sample Output
YES


简单数论;

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define MAXN 10
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

int f[MAXN] = {1}, n;

int main()
{
for(int i=1; i<MAXN; i++) f[i] = f[i-1]*i;
while(~scanf("%d", &n) && n >= 0) {
if(n == 0) { puts("NO"); continue; }
for(int i=9; i>=0&&n!=0; i--) if(n >= f[i]) {
n -= f[i];
}
if(!n) puts("YES");
else puts("NO");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数论