您的位置:首页 > 产品设计 > UI/UE

PAT A 1007. Maximum Subsequence Sum (25)

2014-05-05 16:51 232 查看
原题

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni,
Ni+1, ..., Nj } where 1 <= i <= j <= K. TheMaximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given
sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum
subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole
sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4


即求和最大的子串的头和尾。

最原始的方法就是暴力扫描所有的子串,n^2,也可以AC。

比较高效的方法单次扫描O(n):从头到尾扫,记录头、和;

1、当和大于等于0时,比较下和是否比暂存的最大的子串的和大,是则暂存头、尾、和;

2、当和小于0时,将和置为0,把头置为下一个数,重新开始

代码:

#include <iostream>
using namespace std;

int main()
{
int k,*num,i,j;
int first,last;	//最长子串的子串头,子串尾
long long max,sum;
cin>>k;		//输入数据
num=new int[k];
for(i=0;i<k;i++)
cin>>num[i];

first=-1;
last=-1;
max=-1;
sum=0;
j=0;	//记录正在扫描的串的头
for(i=0;i<k;i++)	//从头向尾扫
{
sum+=num[i];
if(sum<0)	//子串和小于0
{
sum=0;
j=i+1;
}
else		//子串和大于等于0
{
if(sum>max)	//大于之前的最大
{
max=sum;
first=j;
last=i;
}
else if(sum==max)	//等于之前的最大
{
if(i+j<first+last)	//判断序号
{
first=j;
last=i;
}
}
}
}
if(first==-1)	//数全部为负数
{
max=0;
first=0;
last=k-1;
}

cout<<max<<" "<<num[first]<<" "<<num[last];
delete [] num;

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: