您的位置:首页 > 其它

UVA 624 CD ( 01背包 + 逆推路径)

2014-05-04 13:43 337 查看
CD

You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and
have as short unused space as possible.

Assumptions:

number of tracks on the CD. does not exceed 20

no track is longer than N minutes

tracks do not repeat

length of each track is expressed as an integer number

N is also integer

Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD

Input

Any number of lines. Each one contains value N, (after space) number of tracks and durations of the tracks. For example from first line in sample data: N=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes

Output

Set of tracks (and durations) which are the correct solutions and string ``sum:" and sum of duration times.

Sample Input

5 3 1 3 4

10 4 9 8 4 2

20 4 10 5 7 4

90 8 10 23 1 2 3 4 5 7

45 8 4 10 44 43 12 9 8 2

Sample Output

1 4 sum:5

8 2 sum:10

10 5 4 sum:19

10 23 1 2 3 4 5 7 sum:55

4 10 12 9 8 2 sum:45

基本题意:有一个可以录制时长为N分钟的CD,有t首需要录制的音乐,每首音乐必须完全录制,问如何录制才能让CD内剩余的可录制时长最短;

同时要记录下录制进去的音乐是哪几首,按上面的格式输出来;

思路:01背包,并逆推路径;

#include <iostream>
#include <cstring>
using namespace std;

int n,t,k,p;
int val[30];
int dp[1010];
int vis[30][1010];
int kis[30];

int main( )
{
    while(cin>>n>>t&&n&&t)
    {
        for(int i = 1; i <= t; i++)
        {
            cin>>val[i];
        }
        memset(vis,0,sizeof(vis)); ///对数组初始化
        memset(kis,0,sizeof(kis));
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= t; i++)
        {
            for(int j = n; j >= val[i]; j--)
            {
                if(dp[j]<=(dp[j-val[i]]+val[i])) ///01背包的核心,判断放与不放,放则更新数据
                {
                    dp[j]=dp[j-val[i]]+val[i];
                    vis[i][j] = val[i]; ///记录在可放体积为J的情况下,放入的第i件物品的价值
                }
            }
        }
        k = n;
        p = 0;
        for(int i = t; i >= 1 ; i--)
        {
            if(vis[i][k])
            {
                kis[p++] = vis[i][k];
                k -= val[i];  /// 根据01背包求解最优解的过程逆推其路径
            }
        }
        for(int i = p-1; i >= 0 ; i--)
        {
            cout<<kis[i]<<" "; ///根据题目要求,要按‘顺’序输出
        }
        cout<<"sum:"<<dp
<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: