您的位置:首页 > 其它

POJ 1704 Georgia and Bob(尼姆变形)

2014-05-03 20:14 253 查看
原题:http://poj.org/problem?id=1704

尼姆博弈详细解释:/article/8280060.html

Georgia and Bob

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 7208Accepted: 2163
Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example:



Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and
move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be
moved at least ONE step and one grid can at most contains ONE single chessman. The player
who cannot make a move loses the game.

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.

Given the initial positions of the n chessmen, can you predict who will finally win the game?

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second
line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.
Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.
Sample Input
2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output
Bob will win
Georgia will win

题意:给你n个棋子的位置,棋子只能往左移,要移到底,每次至少移动一格,每个格子只能有一个棋子,当棋子不能移动时,那人就输了。(也就是上面红色的翻译)

这道题一开始较难想到怎么用博弈做,但是当你自己一个个去模拟一遍,就知道当棋子两两靠在一起时,先走的就必输了,因为前面的棋子走多少后面的棋子也走多少结果还是靠在一起,当前面一个不能走时也就是输了,这也就是奇异局势。
那要怎么让它们两两相靠呢,那就要看它们之间的间距了,这样题目就一目了然了,根据棋子之间的间距用尼姆博弈解答。
AC代码如下:
#include <cstdio>
#include <algorithm>
#include <iostream>

using namespace std;
/*
author:YangSir
time:2014/5/3
*/
int main()
{
int t,n,a[1005],i,sum;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
a[0]=0;//这个最蛋疼,没有考虑到棋子数为奇数时的情况,wa了几次
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
sort(a,a+n+1);//题目给你棋子位置的大小不一定由小到大
sum=0;
for(i=n;i>0;i=i-2)
{
sum^=(a[i]-a[i-1]-1);//这是算两两间距
}
if(sum==0)
printf("Bob will win\n");
else
printf("Georgia will win\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: