您的位置:首页 > 其它

Factoring Large Numbers 关于线性筛选法打表

2014-05-02 21:06 239 查看

Factoring Large Numbers

One of the central ideas behind much cryptography is that factoring large numbers is computationally intensive. In this context one might use a 100 digit number that was a product of two 50 digit
prime numbers. Even with the fastest projected computers this factorization will take hundreds of years.
You don't have those computers available, but if you are clever you can still factor fairly large numbers.

Input

The input will be a sequence of integer values, one per line, terminated by a negative number. The numbers will fit in gcc's
long long int
datatype. You may assume that there will be
at most one factor more than 1000000.

Output

Each positive number from the input must be factored and all factors (other than 1) printed out. The factors must be printed in ascending order with 4 leading spaces preceding a left justified number,
and followed by a single blank line.

Sample Input

90
1234567891
18991325453139
12745267386521023
-1


Sample Output

2
3
3
5

1234567891

3
3
13
179
271
1381
2423

30971
411522630413

解决方案:由于纸有64bit的长度,所以可先用线性筛选法打表,有题目可知,只需打到1000000范围的素数就可以了。

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#define nmax 10000000
using namespace std;
bool vis[nmax];
long long prime[nmax];
void init_prime()
{
memset(vis,true,sizeof(vis));
long long k=0;
for(long long i=2;i<=nmax;i++)
{
if(vis[i])
{
prime[++k]=i;
}
for(long long j=1;j<=k&&(i*prime[j])<=nmax;j++)
{
vis[i*prime[j]]=false;
if((i%prime[j])==0) break;
}
}
//cout<<k<<endl;
}
int main()
{
init_prime();
long long N;
//cout<<prime[100000];
while(cin>>N)
{
// scanf("%lld",&N);
//  cout<<N;
//getchar();
if(N<0) break;
// if(N==1)  {printf("    1\n");continue;}
for(long long i=1;i<=600000;i++)
{
// cout<<prime[i]<<endl;
// getchar();
while(N%prime[i]==0)
{
cout<<"    "<<prime[i]<<endl;
N/=prime[i];
// cout<<N<<endl;
// getchar();
}
if(N==1) break;
}
if(N!=1) cout<<"    "<<N<<endl;
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: