您的位置:首页 > 其它

poj 3779 Single CPU, multi-tasking(模拟)

2014-05-02 20:50 288 查看
原题:http://poj.org/problem?id=3779

Single CPU, multi-tasking

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 467Accepted: 140
Description

Tuntun is a big fan of Apple Inc. who owns almost all kinds of products the company published. Fascinated by the amazing user experience and fabulous user interface, he spent every nickel of his pocket money on his iMac and iPhone. A few days ago, Apple released
their latest iPhone OS 4.0. Tuntun noticed that the most significant new feature of iPhone OS 4.0 is multi-tasking support. He was curious about why the same device with a single core CPU can support multi-tasking under the new operating system. With his clever
head, he found out a simple solution. The OS doesn’t have to let the CPU run several tasks exactly at the same time. What the OS should do is just to let the user feel that several tasks are running at the same time. In order to do that, the OS assigns the
CPU to the tasks in turn. When the acts of reassigning a CPU from one task to another occur frequently enough, the illusion of parallelism is achieved. Let’s suppose that the OS makes each task run on the CPU for one millisecond every time in turn, and when
a task is finished, the OS assigns the CPU to another task immediately. Now if there are 3 tasks which respectively need 1.5, 4.2 and 2.8 millisecond to complete, then the whole process is as follows:

At 0th millisecond, task 1 gets the CPU. After running for 1 millisecond, it still needs 0.5 milliseconds to complete.

At 1st millisecond, task 2 gets the CPU. After running for 1 millisecond, it still needs 3.2 milliseconds to complete.

At 2st millisecond, task 3 gets the CPU. After running for 1 millisecond, it still needs 1.8 milliseconds to complete.

At 3rd millisecond, task 1 comes back to CPU again. After 0.5 millisecond of running, it is finished and will never need the CPU.

At 3.5 millisecond, task 2 gets the CPU again. After running for 1 millisecond, it still needs 2.2 milliseconds to complete.

At 4.5 millisecond, it’s time for task 3 to run. After 1 millisecond, it still needs 0.8 milliseconds to complete.

At 5.5 millisecond, it’s time for task 2 to run. After 1 millisecond, it still needs 1.2 milliseconds to complete.

At 6.5 millisecond, time for task 3. It needs 0.8 millisecond to complete, so task 3 is finished at 7.3 milliseconds.

At 7.3 millisecond, task 2 takes the CPU and keeps running until it is finished.

At 8.5 millisecond, all tasks are finished.

Tuntun decided to make a simple iPhone multi-tasking OS himself, but at first, he needs to know the finishing time of every task. Can you help him?

Input

The first line contains only one integer T indicates the number of test cases.

The following 2×T lines represent T test cases. The first line of each test case is a integer N (0 < N *lt;= 100) which represents the number of tasks, and the second line contains N real numbers indicating the time needed for each task. The time is in milliseconds,
greater than 0 and less than 10000000.
Output

For each test case, first output “Case N:”, N is the case No. starting form 1. Then print N lines each representing a task’s finishing time, in the order correspondent to the order of tasks in the input. The results should be rounded to 2 digits after decimal
point, and you must keep 2 digits after the decimal point.
Sample Input
2
3
1.5 4.2 2.8
5
3.5 4.2 1.6 3.8 4.4

Sample Output
Case 1:
3.50
8.50
7.30
Case 2:
14.10
17.10
7.60
15.90
17.50

这道题没什么好的方法,就是模拟一下过程,能优化就优化,看你的头脑风暴怎么样☺要YY哦~~
AC代码如下:
#include <cstdio>
#include <cstring>
#include <string>
#include <iostream>

using namespace std;

#define max 10000000
/*
author:YangSir
time:2014/5/2
*/
int main()
{
int t,n,p,i,j,k,num;
double a[125],b[125],sum,min;
scanf("%d",&t);
k=1;
for(k=1;k<=t;k++)
{
memset(b,0,sizeof(b));
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%lf",&a[i]);
}
sum=0;
while(1)
{
min=max;
for(j=0;j<n;j++)
{
if(a[j]==0)
continue;
p=a[j];
if(p==a[j])
p--;
if(p<min)
min=p;
}//求出最小的有1的情况
for(j=0;j<n;j++)
{
if(a[j]==0)
continue;
a[j]-=min;
sum+=min;
}

for(j=0;j<n;j++)
{
if(a[j]==0)
continue;
if(a[j]<=1)//小于1的情况
{
sum+=a[j];
b[j]=sum;
a[j]=0;
}
else//大于1的情况
{
a[j]--;
sum++;
}
}
for(i=0;i<n;i++)
{
if(a[i])
break;
}
if(i==n)
break;//全为0
}
printf("Case %d:\n",k);
for(i=0;i<n;i++)
{
printf("%.2lf\n",b[i]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: