您的位置:首页 > 其它

hdu 1163 Eddy's digital Roots(九余数定理)

2014-05-02 20:18 489 查看
hdu 1163 Eddy's digital Roots

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is
repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.

 

Input

The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).

 

Output

Output n^n's digital root on a separate line of the output.

 

Sample Input

2
4
0

 

Sample Output

4
4

 

Author

eddy

 

/***********************

看FFT看的头晕还是没看懂,然后回头刷水题,想找点快感,没想到碰到个小炸弹。。。

用到了一个九余数定理,不知道这个定理确实很难做……

九余数定理简介:一个数N  各位数字的和 对9 取余等于 这个数对 9取余。。

太坑了,记下来,免得以后忘了……

**********************/
#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
int n,i,s;
while(scanf("%d",&n)&&n)
{
s = 1;
for(i = 1;i<=n;i++){
s=s*n%9;
}
if(s==0) printf("9\n");
else printf("%d\n",s);
}
return 0;
}


太坑了……
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数学 九余数定理