您的位置:首页 > 其它

hdoj-1240-Asteroids!(dfs和bfs)

2014-05-02 09:29 288 查看

Asteroids!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3163 Accepted Submission(s): 2110



Problem Description
You're in space.

You want to get home.

There are asteroids.

You don't want to hit them.



Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.



Output
For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to
the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.



Sample Input
START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END




Sample Output
1 0
3 4
NO ROUTE/*题意:三维空间,X为星星不能走,O为空间,求从起始坐标到目标坐标的最短距离,或无法到达,广搜和深搜都AC*/bfs队列用法:
empty(); 队列为空返回
pop();   出队
push();  入队
front();   返回队列中最先进入的元素
本题推荐用bfs.
bfs代码:[code]#include<iostream>
#include<string.h>
#include<stdio.h>
#include<queue>
using namespace std;
char map[11][11][11],visit[11][11][11];
int dir[6][3]={1,0,0,-1,0,0,0,1,0,0,-1,0,0,0,1,0,0,-1};//方向
int x,y,z,num,startx,starty,startz,endx,endy,endz;
struct node
{
	int x,y,z,step;
};
int check(int x,int y,int z)//检查该位置是否可以走
{
	if(x>=0&&x<num&&y>=0&&y<num&&z>=0&&z<num&&map[z][x][y]!='X'&&visit[z][x][y]==0) return 1;
	return 0;
}
int bfs(int x,int y,int z)//搜索
{
	node st,ed;
	int i,j;
	queue<node>que;//创建队列
	st.x=x;st.y=y;st.z=z;st.step=0;
	que.push(st);visit[z][x][y]=1;
	while(!que.empty())//队列不为空
	{
		st=que.front();
		if(st.x==endx&&st.y==endy&&st.z==endz) return st.step;
		que.pop();
		for(i=0;i<6;i++)//向六个方向搜索
		{
			ed.x=st.x+dir[i][0];
			ed.y=st.y+dir[i][1];
			ed.z=st.z+dir[i][2];
			if(check(ed.x,ed.y,ed.z))
			{
				
				visit[ed.z][ed.x][ed.y]=1;
				ed.step=st.step+1;
				que.push(ed);
			}
		}
	}
	return -1;
}
int main()
{
	char f[20];
	while(cin>>f>>num)
	{
		getchar();
		for(x=0;x<num;x++)
			for(y=0;y<num;y++)
				for(z=0;z<num;z++)
					cin>>map[x][y][z];
				cin>>startx>>starty>>startz>>endx>>endy>>endz;
				cin>>f;
				memset(visit,0,sizeof(visit));
			z=bfs(startx,starty,startz);
			if(z==-1) cout<<"NO ROUTE"<<endl;
			else cout<<num<<" "<<z<<endl;
	}
	return 0;

}
dfs代码:#include<iostream>
using namespace std;
char map[11][11][11];
int sum,startx,starty,startz,endx,endy,endz,num;
char c[100];
int f[6][3]={1,0,0,-1,0,0,0,1,0,0,-1,0,0,0,1,0,0,-1};//六个方向
int DFS(int z,int x,int y,int l)//搜索l记录走的长度
{
int i,j;
if(x<1||x>num||y>num||y<1||z<1||z>num) return 0;
if(map[z][x][y]=='X') return 0;
else if(x==endx&&y==endy&&z==endz)
{
if(l<sum) sum=l;
return 0;
}
for(i=0;i<6;i++)
{
map[z][x][y]='X';
DFS(z+f[i][0],x+f[i][1],y+f[i][2],l+1);
//不用重置
}

return 0;
}
int main()
{
int i,j,k;
while(cin>>c)
{
cin>>num;
for(i=1;i<=num;i++)
for(j=1;j<=num;j++)
for(k=1;k<=num;k++)
cin>>map[i][j][k];
cin>>startx>>starty>>startz>>endx>>endy>>endz;
cin>>c;
sum=2000;
startx+=1;starty+=1;startz+=1;
endx+=1;endy+=1;endz+=1;
DFS(startz,startx,starty,0);
if(sum==2000) cout<<"NO ROUTE"<<endl;
else cout<<num<<" "<<sum<<endl;
}
return 0;
} [/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: