您的位置:首页 > 其它

How many prime numbers

2014-05-01 22:42 253 查看


How many prime numbers


Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)


Total Submission(s) : 9   Accepted Submission(s) : 4


Problem Description

Give you a lot of positive integers, just to find out how many prime numbers there are.

 

Input

There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.

 

Output

For each case, print the number of prime numbers you have found out.

 

Sample Input

3
2 3 4

 

Sample Output

2

 

Author

wangye

 
代码如下:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int main()
{
int n;
int x;
while(scanf("%d",&n)!=EOF)
{
if(n == 0)continue;
int res = 0;
for(int i = 0; i < n; i ++)
{
scanf("%d",&x);
int flag = 1;
for(int i = 2; i <= (int)sqrt(x); i ++)
{
if(x % i == 0){
flag = 0;
break;
}
}
if(flag) res ++;
}
printf("%d\n",res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数论