您的位置:首页 > 其它

poj 2342 Anniversary party 简单树形dp

2014-04-29 09:09 288 查看
Anniversary party

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3862 Accepted: 2171
Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make
the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your
task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127.
After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 

L K 

It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 

0 0 

Output

Output should contain the maximal sum of guests' ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output
5


【题意】

公司有n个人,每个人有价值vi,有一天举办年会,每个人都可以参加,但有严格的等级制度,参加活动时,不能同时出现a和a的上司,问如何才能使总和最大。

【分析】

每个人只有去和不去两种状态,设DP[i][0]和DP[i][1]分别表示第i个人不参加和参加年会,获得的总的最大价值。

则状态转移方程为:

DP[i][1] += DP[j][0],

DP[i][0] += max{DP[j][0],DP[j][1]};其中j为i的孩子节点。

这样,从根节点r进行dfs,最后结果为max{DP[r][0],DP[r][1]}。

(分析来自yzmduncan

第2~n+1行为这n个人的价值

#include "stdio.h" //简单的树形dp题
#include "string.h"
#include "queue"
using namespace std;

#define N 60005
#define INF 0x3fffffff

struct node
{
int x,y;
int weight;
int next;
}edge[4*N];
int idx,head
;

int root;
int du
;
int value
;

int dp
[2];
int MAX(int a,int b) { return a>b?a:b; }

void Init()
{
idx = 0;
memset(head,-1,sizeof(head));
}

void Add(int x,int y,int weight)
{
edge[idx].x = x;
edge[idx].y = y;
edge[idx].weight = weight;
edge[idx].next = head[x];
head[x] = idx++;
}

void DFS(int i) //
{
int k,j;
dp[i][0] = 0;
dp[i][1] = value[i];
for(k=head[i]; k!=-1; k=edge[k].next)
{
j = edge[k].y;
DFS(j);
dp[i][0] += MAX(dp[j][0],dp[j][1]);
dp[i][1] += dp[j][0];
}
}

int main()
{
int n;
int i;
int x,y;
while(scanf("%d",&n)!=EOF)
{
Init();
memset(du,0,sizeof(du)); //记录节点的入度
memset(dp,0,sizeof(dp));
for(i=1; i<=n; ++i)
scanf("%d",&value[i]);
while(scanf("%d %d",&x,&y) && x+y>0)
{
Add(y,x,0);
du[x]++;
}
for(i=1; i<=n; ++i)
{
if(du[i]==0)
root = i;
}
DFS(root);
printf("%d\n",MAX(dp[root][0],dp[root][1]));
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法