您的位置:首页 > 其它

The area (HDU 1071)

2014-04-27 07:33 302 查看
这题是求面积的,属于数学题。刚看到这道题时,觉得很难,因为要用到微积分,而且二次函数中的a,b,c也不知道该怎么求。
后来学长告诉我这题不难,所以我就仔细的想了想,发现可以通过二次函数的顶点坐标式求出a,然后其他的变量都可以求出来了,于是这题很快写出来了。。

The area

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7130 Accepted Submission(s): 5010



Problem Description
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture,
can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.



Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

Sample Input
2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222


Sample Output
33.33
40.69

Hint
For float may be not accurate enough, please use double instead of float.


代码如下:
#include"stdio.h"
#include"math.h"
int main()
{
    int n;
    double x1,y1,x2,y2,x3,y3;
    double a,b,c,k,t;
    while(~scanf("%d",&n))
    while(n--)
    {
        scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3);
        a=(y2-y1)/pow((x2-x1),2);
        b=-2*a*x1;
        c=y1-a*x1*x1-b*x1;
        k=(y3-y2)/(x3-x2);
        t=y3-k*x3;
        double area1,area2;
        area1=1.0/3*a*pow(x3,3)+1.0/2*(b-k)*pow(x3,2)+(c-t)*x3;
        area2=1.0/3*a*pow(x2,3)+1.0/2*(b-k)*pow(x2,2)+(c-t)*x2;
        printf("%.2lf\n",area1-area2);
    }
    return 0;
}


注意倒数第5,6行是1.0/3,不是1/3,就是因为这个搞得开始我不知道哪错了。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: