您的位置:首页 > 其它

Add ‘em 2162

2014-04-26 23:49 232 查看
Problem Description

Write a program to determine the summation of several sets of integers.

Input

The input file will consist of up to 250 sets of integers, where each set contains at most 100

integers and the integer values will be between –16000 and + 16000. Each set of numbers is

started with the number of integers in the set, n. The next n input lines will each contain one

integer of the set. You should stop processing when the size of the set, n, is<= 0.

Output

A single line of output should be generated for each set of integers. The line should have format

shown below.

Sample Input

4

-1

3

1

1

2

19

17

5

-645

952

-1488

-5456

-9342

-1

Sample Output

Sum of #1 is 4

Sum of #2 is 36

Sum of #3 is -15979

#include <cstdio>

int main(int argc, const char* argv[])
{
int n = 0 ,count = 0;
while (scanf("%d", &n) == 1 && n > 0)
{
int sum = 0, temp = 0;
for (int i=0; i<n; ++i)
{
scanf("%d", &temp);
sum += temp;
}
printf("Sum of #%d is %d\n", ++count, sum);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: