您的位置:首页 > 其它

uva10010 - Where's Waldorf?

2014-04-26 22:00 393 查看


  Where's Waldorf? 
Given a m by n grid
of letters, ( 

),
and a list of words, find the location in the grid at which the word can be found. A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters in the grid regardless of case (i.e. upper and lower case letters are to be
treated as the same). The matching can be done in any of the eight directions either horizontally, vertically or diagonally through the grid.

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank
line between two consecutive inputs.

The input begins with a pair of integers, m followed by n, 

 in
decimal notation on a single line. The next m lines contain n letters each; this is the grid of letters in which the words of the list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters, another
integer k appears on a line by itself ( 

). The next k lines of input contain the list of words to search
for, one word per line. These words may contain upper and lower case letters only (no spaces, hyphens or other non-alphabetic characters).

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For each word in the word list, a pair of integers representing the location of the corresponding word in the grid must be output. The integers must be separated by a single space. The first integer is the line
in the grid where the first letter of the given word can be found (1 represents the topmost line in the grid, and m represents the bottommost line). The second integer is the column in the grid where the first letter of the given word can be found
(1 represents the leftmost column in the grid, and n represents the rightmost column in the grid). If a word can be found more than once in the grid, then the location which is output should correspond to the uppermost occurence of the word (i.e.
the occurence which places the first letter of the word closest to the top of the grid). If two or more words are uppermost, the output should correspond to the leftmost of these occurences. All words can be found at least once in the grid.

Sample Input 

1

8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
4
Waldorf
Bambi
Betty
Dagbert

Sample Output 

2 5
2 3
1 2
7 8


使用vector<string>保存查找的表即可

#include<iostream>
#include<cstdio>
#include<vector>
#include<string>
#include<cctype>
using namespace std;

#define INF 100000000

vector<string> table;

bool IsEqual(char a, char b){
return toupper(a) == toupper(b);
}

bool Left(string str, int i, int j){
int k = 0, m = 0;

for(k = j, m = 0; k >= 0 && m < str.size(); k--, m++){
if(!IsEqual(str[m], table[i][k]))
return false;
}
if(m == str.size())
return true;
return false;
}

bool Right(string str, int i, int j){
int k = 0, m = 0;
for(k = j, m = 0; k < table[i].size() && m < str.size(); k++, m++){
if(!IsEqual(str[m], table[i][k]))
return false;
}
if(m == str.size())
return true;
return false;
}

bool Up(string str, int i, int j){
int k = 0, m = 0;
for(k = i, m = 0; k >= 0 && m < str.size(); k--, m++){
if(!IsEqual(str[m], table[k][j]))
return false;
}
if(m == str.size())
return true;
return false;
}

bool Down(string str, int i, int j){
int k = 0, m = 0;
for(k = i, m = 0; k < table.size() && m < str.size(); k++, m++){
if(!IsEqual(str[m], table[k][j]))
return false;
}
if(m == str.size())
return true;
return false;
}

bool LeftUp(string str, int i, int j){
int l = 0, k = 0, m = 0;
for(l = i, k = j, m = 0; l >= 0 && k >= 0 && m < str.size(); l--, k--, m++){
if(!IsEqual(str[m], table[l][k]))
return false;
}
if(m == str.size())
return true;
return false;
}

bool RightUp(string str, int i, int j){
int l = 0, k = 0, m = 0;
for(l = i, k = j, m = 0; l >= 0 && k < table[i].size() && m < str.size(); l--, k++, m++){
if(!IsEqual(str[m], table[l][k]))
return false;
}
if(m == str.size())
return true;
return false;
}

bool LeftDown(string str, int i, int j){
int l = 0, k = 0, m = 0;
for(l = i, k = j, m = 0; l < table.size() && k >= 0 && m < str.size(); l++, k--, m++){
if(!IsEqual(str[m], table[l][k]))
return false;
}
if(m == str.size())
return true;
return false;
}

bool RightDown(string str, int i, int j){
int l = 0, k = 0, m = 0;
for(l = i, k = j, m = 0; l < table.size() && k < table[i].size() && m < str.size(); l++, k++, m++){
if(!IsEqual(str[m], table[l][k]))
return false;
}
if(m == str.size())
return true;
return false;
}

bool IsTrue(string str, int i, int j){
if(Left(str, i, j)||Right(str, i, j)||Up(str, i, j)||Down(str, i, j)||LeftUp(str, i, j)||LeftDown(str, i, j)||RightUp(str, i, j)||RightDown(str, i, j))
return true;
return false;
}

int main(void){
int num = 0;
int t = 0;
int n = 0, m = 0;
int posx = INF, posy = INF;

#ifndef ONLINE_JUDGE
freopen("f:\\infile.txt", "r", stdin);
#endif

cin >> num;
while(num--){
string str;

cin >> n >> m;
table.clear();
for(int i = 0; i < n; i++){
cin >> str;
table.push_back(str);
}
cin >> t;
while(t--){
posx = INF;
posy = INF;
cin >> str;
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
if(IsTrue(str, i, j)){
if((posx + posy) > (i + j)){
posx = i;
posy = j;
}
}
}
}
cout << posx+1 << " " << posy+1 <<endl;
}
if(num != 0)
cout <<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: