您的位置:首页 > 产品设计 > UI/UE

POJ 2533 : Longest Ordered Subsequence

2014-04-26 09:29 393 查看
                                                                                                                   Longest Ordered Subsequence

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 30983 Accepted: 13518
Description
A numeric sequence of ai is ordered if
a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1,
a2, ..., aN) be any sequence (ai1,
ai2, ..., aiK), where 1 <=
i1 < i2 < ... < iK <=
N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input
7
1 7 3 5 9 4 8

Sample Output
4

这题和拦截导弹一样,dp求最长递增子序列长度。

wa了好几次,原因是sum(最长长度)初始化错了,开始初始化为0,结果一直wa,后来发现只有一个数时,sum没有经过递归比较直接输出0,但答案应该为1,所以sum的初始化应该应注意。

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
#define max(a,b) a>b?a:b;
int dp[10005];
int a[10005];
int main()
{
int n;
scanf("%d",&n);
int sum =  0;
for(int i = 0 ; i < n ; i++)
{
scanf("%d",&a[i]);
dp[i]=1;
}
for(int i = 1 ; i < n ; i++){
for(int j = 0 ; j < i ; j++)
{
if(a[i]>a[j] && dp[i] < dp[j]+1)
dp[i] = dp[j]+1;
}
sum=max(sum,dp[i]);
}
//    for(int i = 0 ; i < n  ;i++)
//    printf("%d ",dp[i]);
//    puts("");
printf("%d\n",sum);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: