您的位置:首页 > 其它

How Many Tables 1213

2014-04-25 18:25 363 查看
Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to

know how many tables he needs at least. You have to notice that not all the friends know each

other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A,

B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and

D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test

cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the

number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of

two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2

5 3

1 2

2 3

4 5

5 1

2 5

Sample Output

2

4

#include <cstdio>
const int MAX = 1001;
int Father[MAX];

void Union(int x, int y);

int main(int argc, const char* argv[])
{
int nCases = 0;
scanf("%d", &nCases);
while (nCases--)
{
int nFriends = 0, nKnows = 0;
scanf("%d%d", &nFriends, &nKnows);
for (int i=1; i<=nFriends; ++i)
{
Father[i] = i;
}

int nFriendA = 0, nFriendB = 0;
for (int i=1; i<=nKnows; ++i)
{
scanf("%d%d", &nFriendA, &nFriendB);
Union(nFriendA, nFriendB);
}

int nTables = 0;
for (int i=1; i<=nFriends; ++i)
{
if (Father[i] == i)
{
++nTables;
}
}

printf("%d\n", nTables);
}

return 0;
}

int Find(int x)
{
if (Father[x] == x)
{
return x;
}
else
{
return Father[x] = Find(Father[x]);
}
}

void Union(int x, int y)
{
int root_x = Find(x);
int root_y = Find(y);
if (root_x != root_y)
{
Father[root_x] = root_y;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: