您的位置:首页 > 其它

DP hdu1505 找最大矩阵

2014-04-24 19:53 134 查看


City Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4232    Accepted Submission(s): 1771


Problem Description

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied.
The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in
each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied
units are marked with the symbol F.

 

Input

The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated
by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.

 

Output

For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

 

Sample Input

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

 

Sample Output

45
0

 

这道题是hdu1506的加强版本,只需先统计每个点上面有多少相邻的F,就是把每一行都模拟成hdu1506的那种形式。这样之后,只需在用hdu1506的方法,统计每一行的最大矩形面积。分别统计每个点左右的相邻比它大的。

#include<iostream>
#include<cstdio>
using namespace std;

char grid[1001][1001];
int hi[1001][1001],l[1001][1001],r[1001][1001];//l[i][j],r[i][j],表示第[i,j]个方格的左右边界
int main()
{
int i,j,k,t,m,n,max;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&m,&n);
for(j=1;j<=n;j++)
hi[0][j]=0;
for(i=1;i<=m;i++)
for(j=1;j<=n;j++)
{
cin>>grid[i][j];
if(grid[i][j]=='F')
hi[i][j]=hi[i-1][j]+1; //记录[i,j]的高度hi[i][j]
else if(grid[i][j]=='R')
hi[i][j]=0;
// cout<<hi[i][j]<<" ";
}
max=0;
for(i=1;i<=m;i++)
{
hi[i][0]=hi[i][n+1]=-1; //把最两端的高度置为-1,方便下面求左右边界

for(j=1;j<=n;j++)
{
k=j-1;
while(hi[i][k]>=hi[i][j])
k=l[i][k];
l[i][j]=k;
}

for(j=n;j>0;j--)
{
k=j+1;
while(hi[i][k]>=hi[i][j])
k=r[i][k];
r[i][j]=k;
}

for(j=1;j<=n;j++) //找最大面积
if((r[i][j]-l[i][j]-1)*hi[i][j]>max)
max=(r[i][j]-l[i][j]-1)*hi[i][j];
}
cout<<max*3<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: