您的位置:首页 > 编程语言 > C语言/C++

Pascal's Travels hdu 1208 子状态继承的dp问题,值得一做

2014-04-23 17:14 344 查看


Pascal's Travels

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1572    Accepted Submission(s): 689


Problem Description

An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away
from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further
progress. 

Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed. 



Figure 1



Figure 2

 

Input

The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed
by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.

 

Output

The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board. 

 

Sample Input

4
2331
1213
1231
3110
4
3332
1213
1232
2120
5
11101
01111
11111
11101
11101
-1

 

Sample Output

3
0
7

HintHint
Brute force methods examining every path will likely exceed the allotted time limit.
64-bit integer values are available as "__int64" values using the Visual C/C++ or "long long" values
using GNU C/C++ or "int64" values using Free Pascal compilers.

 

Source

Mid-Central USA 2005

 

Recommend

mcqsmall

这个问题是个其实特别像是搜索题目,但是搜索又不好过,所以子状态继承的dp是最佳的选择,其实就是把
各个状态的路程都走到,求出在那个状态下的数目,就是有几种方法可以走到那的数目,
所以从(0,0)到(n-1,n-1)   就好了。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char map[50][50];
__int64 dp[50][50];
int main()
{
int i,j,k,n;
while(scanf("%d",&n)!=EOF)
{
if(n==-1)
break;
memset(dp,0,sizeof(dp));
for(i=0;i<n;i++)
{
scanf("%s",map[i]);
}
dp[0][0]=1;
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
if(map[i][j]-'0')
{

if(i+map[i][j]-'0'<n)
{
dp[i+map[i][j]-'0'][j]=dp[i][j]+dp[i+map[i][j]-'0'][j];
}
if(j+map[i][j]-'0'<n)
{
dp[i][j+map[i][j]-'0']=dp[i][j]+dp[i][j+map[i][j]-'0'];

}
}

}

}

printf("%I64d\n",dp[n-1][n-1]);

}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息