您的位置:首页 > 其它

hdu 1045:Fire Net(DFS经典题)

2014-04-22 22:53 483 查看

Fire Net

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5863 Accepted Submission(s): 3280


[align=left]Problem Description[/align]
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

[align=left]Input[/align]
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

[align=left]Output[/align]
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

[align=left]Sample Input[/align]

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0


[align=left]Sample Output[/align]

5
1
5
2
4

[align=left]Source[/align]
Zhejiang University Local Contest 2001

[align=left]Recommend[/align]
We have carefully selected several similar problems for you: 1050 1067 1258 1053 1789

  DFS深搜经典题

  暴力穷举即可,数据规模大的话据说可以用二分匹配,另外这道题也可以用贪心来做。
  贪心做法可见博客:http://blog.csdn.net/suifengdream/article/details/8590581
  二分匹配可见博客:http://hi.baidu.com/xiaotiandm/item/949ef8d2e5c8914ffa576834
  代码: 
 

#include <iostream>

using namespace std;
char a[5][5];
int cnt,n;
bool judge(int x,int y)   //判断这一步可不可以走
{
if(a[x][y]=='X')
return 1;
if(a[x][y]=='*')
return 1;
int i;
//判断这一行上有无碉堡
for(i=y;i>=1;i--){
if(a[x][i]=='*')
return true;
if(a[x][i]=='X')
break;
}
for(i=y;i<=n;i++){
if(a[x][i]=='*')
return true;
if(a[x][i]=='X')
break;
}
//判断这一列上有无碉堡
for(i=x;i>=1;i--){
if(a[i][y]=='*')
return 1;
if(a[i][y]=='X')
break;
}
for(i=x;i<=4;i++){
if(a[i][y]=='*')
return 1;
if(a[i][y]=='X')
break;
}
//可以走
return 0;
}
void dfs(int cx,int cy,int cn)
{
if(cn>cnt) cnt=cn;    //记录最大值
int x=-1,y=-1;
int i,j;
for(i=cx;i<=n;i++)   //选择这一步的位置
for(j=1;j<=n;j++){
if(i==cx && j<=cy)
continue;
if(judge(i,j))
continue;
x=i;y=j;
a[x][y] = '*';
dfs(x,y,cn+1);
a[x][y] = '.';
}
if(x==-1 && y==-1)
return ;
}
int main()
{
while(cin>>n){
if(n==0) break;
int i,j;
for(i=1;i<=n;i++)   //输入地图
for(j=1;j<=n;j++)
cin>>a[i][j];
cnt = 0;
dfs(1,0,0);  //深搜
cout<<cnt<<endl;
}
return 0;
}


Freecode : www.cnblogs.com/yym2013
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: