您的位置:首页 > 其它

UVa - 414 - Machined Surfaces 题解

2014-04-22 16:07 435 查看
An imaging device furnishes digital images of two machined surfaces that eventually will be assembled in contact with each other. The roughness of this final contact is to be estimated.

A digital image is composed of the two characters, "X" and " " (space). There are always 25 columns to an image, but the number of rows, N, is variable. Column one (1) will always have
an "X" in it and will be part of the left surface. The left surface can extend to the right from column one (1) as contiguous X's.

Similarly, column 25 will always have an "X" in it and will be part of the right surface. The right surface can extend to the left from column 25 as contiguous X's.
Digital-Image View of Surfaces

Left     		                           Right

		 [code]XXXX                                              XXXXX



XXX                                             XXXXXXX


XXXXX                                              XXXX


XX                                               XXXXXX


.                                                     .


.                                                     .


.                                                     .


XXXX                                               XXXX


XXX                                              XXXXXX










1 25

[/code]
In each row of the image, there can be zero or more space characters separating the left surface from the right surface. There will never be more than a single blank region in any row.

For each image given, you are to determine the total ``void" that will exist after the left surface has been brought into contact with the right surface. The ``void" is the total count of the spaces that remains
between the left and right surfaces after theyhave been brought into contact.

The two surfaces are brought into contact by displacing them strictly horizontally towards each other until a rightmost "X" of the left surface of some row is immediately to the left of the leftmost "X" of
the right surface of that row. There is no rotation or twisting of these two surfaces as they are brought into contact; they remain rigid, and only move horizontally.

Note: The original image may show the two surfaces already in contact, in which case no displacement enters into the contact roughness estimation.

Input

The input consists of a series of digital images. Each image data set has the following format:

First line -A single unsigned integer, N, with value greater than zero (0) and less than 13. The first digit of Nwill be the first character on a line.

Next N lines -Each line has exactly 25 characters; one or more X's, then zero or more spaces, then one or more X's.

The end of data is signaled by a null data set having a zero on the first line of an image data set and no further data.

Output

For each image you receive as a data set, you are to reply with the total void (count of spaces remaining after the surfaces are brought into contact). Use the default output for a single integer on a line.

Sample Input (character "B" for ease of reading. The actual input file will use the ASCII-space character,
not "B").

4
XXXXBBBBBBBBBBBBBBBBXXXXX
XXXBBBBBBBBBBBBBBBXXXXXXX
XXXXXBBBBBBBBBBBBBBBBXXXX
XXBBBBBBBBBBBBBBBBBXXXXXX
2
XXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXX
1
XXXXXXXXXBBBBBBBBBBBBBBXX
0


Sample Output

4
0
0


看起来好复杂的题目,但是其实意思就是:有左右两边的两种又x组成的字符组,如果组合在一起,那么中间会留下多少空格呢?组合的时候是以最长的字符相碰为准。

所以算法思路也是如此:

1 计算出最大的一行,左右字符加起来

然后使用这个数值减去所有行的字符长度,就是最终结果了

注意: 当字符达到25个字符的时候,使用cin>>string处理的要注意不要过多输入了,先判断一下就好了,看代码:

#include <string>
#include <algorithm>
#include <queue>
#include <vector>
#include <stdio.h>
#include <iostream>
using namespace std;
/*
注意情况:
刚好是25个字符一行的情况,就不能使用两次cin>>s了
*/
void MachinedSurfaces()
{
	int rows = 0;
	string left, right;
	while (cin>>rows && 0 != rows)
	{
		vector<int> A(rows);
		int max_len = 0;
		for (int i = 0; i < rows; i++)
		{
			cin>>left;
			if (left.size() < 25) cin>>right;
			else right.clear();
			left += right;
			A[i] = (int)left.size();
			max_len = max(max_len, A[i]);
		}
		int ans = 0;
		for (int i = 0; i < rows; i++)
		{
			ans += max_len - A[i];
		}
		cout<<ans<<endl;
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: