您的位置:首页 > 其它

POJ-1579 Function Run Fun

2014-04-20 18:30 288 查看
Function Run Fun

Time Limit: 1000MS Memory Limit: 10000K
   
Description

We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 



if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 

w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 

w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 

w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output

Print the value for w(a,b,c) for each triple.
Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

Source
Pacific Northwest 1999
————————————————————心乱的分割线————————————————————
思路:最裸的记忆化搜索,裸就裸在直接跟你说,你在哪需要记忆化一下。
对于DFS,重复的计算是相当浪费时间的。这时候就需要利用参数和数组进行记忆化。对DFS来说,参数意味着状态。某一状态如果已经计算,直接返回值就行了。如果并不能确定0能否代表该状态是否已经计算,就要另开一个vis数组。
代码如下:
/****************************************/
#include <cstdio>
#include <cstring>
/****************************************/
bool vis[25][25][25];
int ans[25][25][25];
int w(int a, int b, int c) {
int ret;//小技巧,精简代码
if(a <= 0 || b <= 0 || c <= 0)
return 1;
else if(a > 20 || b > 20 || c > 20)
return w(20, 20, 20);
if(vis[a][b][c])//如果存在记忆,直接返回答案
return ans[a][b][c];
vis[a][b][c] = true;//记忆化
if(a < b && b < c) {
ret = w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c);
} else {
ret = w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1);
}
return ans[a][b][c] = ret;//返回答案值的同时储存进数组中
}
int main() {
int a, b, c;
while(~scanf("%d%d%d", &a, &b, &c), a!=-1||b!=-1||c!=-1) {
memset(vis, 0, sizeof(vis));
printf("w(%d, %d, %d) = %d\n", a, b, c, w(a, b, c));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: